x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Restoring IAP occasionally don't work

I added the restore IAP node to my game, it work and all but not all the time, when i successfully restore the item, i close my game and relaunch it and try again and it tell me to purchase the item again, and when i do it say that i already purchase the item.

Is this a problem with sandbox ? is this a bug ?

My blueprint is setup just like match3 doc.

EDIT : On the branch node I connected the false output back to restore IAP Restore node and it work. any particular reason why is doing this ?

Product Version: UE 4.12
Tags:
more ▼

asked Sep 30 '16 at 12:33 PM in Bug Reports

avatar image

Juanjose09
111 9 14 22

avatar image Samantha Sutton ♦♦ STAFF Sep 30 '16 at 05:38 PM

JuanJose09,

  • Have you tested this in 4.13 or 4.13.1?

  • What device are you on?

  • Do you have any logs that you would be able to provide?

When comparing your blueprint to the one in Unreal Match 3, I noticed that you're missing the macro that has the back-end information for the purchase state. Also if you notice, there is a custom event created for the Restore IAP node which includes a node for the in-store widget, yours doesn't seem to have that.

avatar image Juanjose09 Sep 30 '16 at 07:59 PM
  • No

  • iPhone 6

  • No, it's doesn't crash

How to properly set up the macro ? What do i need to add in order gadder information for the purchase state ? In the doc doesn't show any information on the macro. That custom event that you're are talking about is it " Read In App " ?

Here's a update

In the branch node in my blueprint, on false, i plug it in to Restore node and this time it work, i relaunch the game multiple time keep workings. However this is not ideal why is not connecting on first try ?

avatar image Juanjose09 Oct 04 '16 at 12:32 PM

So... ?

Any idea why is taking to long to restore the purchase ?

After testing the restored feature(through sandbox), the way a got it to work(connecting the false branch back to the restore) is not ideal it take extremely long time to restore.

i was digging information about macro and looking at unreal doc it look like it calling the same success,fail twice. What do i need to add inside the macro ?

avatar image Samantha Sutton ♦♦ STAFF Oct 07 '16 at 03:54 PM

I would honestly suggest creating a copy of your project in 4.13.1 and seeing whether or not your IAP restores are working quicker or not.

Macro Documentation:

I went in and modified the Unreal Match 3 blueprint to look more similar to yours and proceeded to make a purchase. I made sure to remove the macro, as that may not be the issue on yours, as it seems the macro relates back information regarding the purchase itself - you should be able to leave that out. I did not notice any sluggishness or slowness, I also checked with others here who work with Unreal Match 3 more often and they too haven't seen any problems with IAP or Restore IAP.

You are more than welcome to upload your project and provide it to me through a private message on the forums.

Thanks!

avatar image Juanjose09 Oct 07 '16 at 04:31 PM

If you don't mind me asking ¿ did you test it through sandbox or through the app store ? ever since i submitted my game through the app store sandbox stop working, i can't get the log in to appear.

Is this how it work ? if i submit my app through the app store i can no longer test it through sandbox ? not even creating new user will work.

Thanks for the doc, once i get sandbox working again i will try a couple more test if not i will send you the project.

avatar image Samantha Sutton ♦♦ STAFF Oct 10 '16 at 05:46 PM

I tested through an account which connects with Game Center. Game Center does not support Sandbox Accounts anymore. I had originally thought it was a Sandbox Account because I had used those previously, hadn't realized they changed. :)

avatar image Juanjose09 Oct 12 '16 at 01:03 PM

Okay here's a update

I updated my engine to 4.13.1, however i cannot test the restore issue because of sandbox, i cannot get it to work, i can't get the "log in " to appear. Do i need to change or add something to the game once it's live on the App Store ? Do i need to change the certificate or the provision ? The IAP status are approved, so i really don't know what going on.

I created a new project, set it up with itunes connect, new IAP, the status are " ready for submit " but nothing it won't work either.

I package the game with checking and Unchecked the Distribution box, packaging for development and shipping don't work either.

It's does however prompt me to sign to my itunes account, after doing some research it look like it sending me to production environment not the sandbox environment, any reason why it doing this ? how do i switch back to sandbox environment ?

After my game was approved by the app store, i tried to upload a updated version (1.1) however i got rejected 3 time, the result where about the restore feature,but the strange thing is on the third rejection i got another message saying that my app din't have IPv6 something, I don't know if this have something to do with sandbox but i wanted to point that out. But by the first rejection i was already having trouble with sandbox.

I hope you can help me with this, i can't find any information on why this is happening.

avatar image Samantha Sutton ♦♦ STAFF Oct 12 '16 at 05:29 PM

Please make sure that you've followed this documentation completely. I'd also review the information given from Apple, it looks like they also have some guides about not having a Sandbox account anymore.

avatar image Juanjose09 Oct 13 '16 at 01:59 PM

I'm aware that Game Center doesn't work with sandbox anymore but my issue is not with Game Center, my issue is with In-App Purchase & Restoring. Apparently i can't connect to the sandbox environment. The messages i receive when i got rejected said that they made a purchase and restore it successfully , however i'm missing a feature, in order to fix it i need to connect to sandbox environment but every time i package my game and launch it to my device i'm getting connected to the production environment not the sandbox environment, how do i switch environment ?

Is this have to do with Certificate and Provision ? For development i'm using the " IOS App Development " for certificate and provision, and as for Production i'm using " App Store and Ad Hoc " for certificate and for provision i'm using " App Store ". In AppID the In App Purchase and Game Center are enable. Do i have this Correct ? if so what else can be causing this issue ?

avatar image Samantha Sutton ♦♦ STAFF Oct 13 '16 at 02:58 PM

You can't connect to the Sandbox Environment, because Sandboxes are disabled by Apple.

From Apple: As part of the release of iOS 9 and El Capitan, the Game Center development sandbox has been eliminated, allowing all pre-release development to occur in exactly the same server environment as released games. This change brings several advantages including:

  • Simplifying update testing by allowing testers to play with the full player base, not just other testers

  • Removing any implementation differences between the sandbox and release environments

Can you upload an image of the error that you're getting when you're rejected, or the message provided?

avatar image Juanjose09 Oct 13 '16 at 03:51 PM

I think i know what causing the rejection, i din't add a restore button, i added the function but i realize i couldn't test it because of sandbox.

The other message i got in the last rejection was due because of the IPv6. After doing some research i found out this post

https://answers.unrealengine.com/questions/480693/iap-enabled-apps-get-rejected-from-ios-store.html

so i updated the engine and added the function but i want to test it before submitting again but i can't know.

If sandbox don't work on release app ¿how do i test new function like In-App Purchase, Restoring ect. On new update ?

avatar image Juanjose09 Oct 13 '16 at 03:53 PM

More Screenshot.

Update

I call apple support and i explain the situation and apparently sandbox still work with release app and approved In-App Purchase. The problem is in my end or there's a bug please read carefully my issue is not or have anything to do with Game Center. My game is not connecting to sandbox, i cannot test or make purchase nor restore a product.

avatar image Ravlek STAFF Oct 17 '16 at 05:58 PM

You will need to create tester accounts in iTunes Connect to test IAP. These are called Sandbox tester accounts. See here for how to set them up. After that follow the instructions here to do that actual testing.

-Pete

avatar image Juanjose09 Oct 26 '16 at 03:35 PM

I don't know why this is resolve because the original issue haven't been resolve just the road block.Here's a update regarding the original issue.

So my update got approve by the App Store yesterday but i still find a issue with not just Restoring Purchases but also when attempting to make a purchase, on first couple of attempt both fail on (Restoring and making the purchase) i need to keep trying until it eventually let me purchase or restoring the purchase. ¿ What can be causing this ?

avatar image Samantha Sutton ♦♦ STAFF Oct 31 '16 at 07:03 PM

I have scoured our Jira and have not been able to find any reports of what you're describing. I installed Unreal Match 3 on an iOS device and haven't ran into any complications.

  • Is this happening on all iOS devices?

  • Are you having reports from users having trouble?

  • Do you have any iOS logs?

  • What about logs from any users?

  • Which devices have you tried so far?

  • What OS versions?

Looking forward to hearing back from you, thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey JuanJose09,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!

more ▼

answered Nov 07 '16 at 08:35 PM

avatar image Juanjose09 Nov 08 '16 at 05:52 PM

I currently looking for more ios device and testers.

The version i test it where 9.3.2 and the latest 10.1

I haven't been getting report from other users because i eliminated In-App Purchase and made my game full retail price because of this issue.

As soon i get more device or testers and test the game, i will post the result here.

avatar image Samantha Sutton ♦♦ STAFF Nov 08 '16 at 10:26 PM

Sounds good, let us know once we can help you!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question