x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.13.1 iOS Provision not found despite being valid.

When I try to package my game for iOS I immediately get 2 errors that say.

"Provision not found. A provision is required for deploying your app to the device."

"Signing key not found. The app could not be digitally signed, because the signing key is not configured."

When I packaged last week with 4.13(before the 4.13.1 fix) I was able to package successfully, but after the update I have this problem.

So far I have re-downloaded the provision and re-verified the engine without success.

I have included my logs from the editor when I try to package. http://pastebin.com/tzbUtZ4H

Product Version: UE 4.13
Tags:
more ▼

asked Sep 30 '16 at 05:43 PM in Packaging & Deployment

avatar image

Aakrasia
206 9 18 18

avatar image Steve Hardister ♦♦ STAFF Oct 05 '16 at 07:18 PM

Hi path3tic,

What system are you on, Mac or PC? In your Project Settings>iOS>are your certificates and provisons high-lighted green and do they say "valid?" Under Project Settings>Packaging: What are you packaging for; Development or Shipping? Make sure your Bundle Identifier matches what you have set up as an Apple Developer: you will need to sign into your Apple dev account to check this. Finally, if on a Mac, check your Certificates in your KeyChain Access window and be sure they are up to date. You may have to update your certificates and provisions.

Let me know if none of these resolve your issue; be sure to note what you tried and what you did not.

Steve H.

avatar image Aakrasia Oct 06 '16 at 12:18 PM

Steve

I am on a Mac

My certs and provisions do say "valid". Furthermore, I have been able to packing with these and upload to the app store in the past few weeks successfully.

Neither development nor shipping work, although they both did in the past.

I double checked the bundle identifier from my dev account and they are the same.

I also opened the keychain access and my certificates are up to date.

Thanks for your help.

avatar image Alan Webster Oct 08 '16 at 11:17 PM

i have the same problem Mac Book Pro Osx 10.11.6 Xcode 8 UE4.13.1

avatar image SkyHigh Oct 09 '16 at 01:29 PM

Hello everyone,

I had this issue and got past it after doing the following. Hopefully it will work for you as well.

On mac, my provisioning profiles were marked as valid, but builds failed immediately after starting claiming that the provision was not found. After some frustration I noticed that their naming was different than on PC. The names given on mac was a long string of letters, numbers and some dashes while the PC version had the project name instead. Renaming them to fit the PC scheme, [projectname].mobileprovision or Distro_[projectname].mobileprovision, and placing them in ~ [projectfolder]/Build/IOS, made them appear alongside the other profiles in the editor after restarting it. Picking the renamed provisioning profiles made it possible to get past the problem.

In short, rename your profile files to [projectname].mobileprovision or Distro_[projectname].mobileprovision, and place them in ~ [projectfolder]/Build/IOS, then pick them as they appear in the editor after a restart.

I'm thinking the issue could be a change in how the profiles are handled. I'm sure it worked in older versions of the editor to just get the profiles through xcode or download and run them, adding them to the key chain. It seems that now the editor still sees the profiles in the key chain and recognizes that they are valid, but fail to access them when the time comes to build.

avatar image Aakrasia Oct 10 '16 at 05:27 PM

It looks like this was the answer. What a strange thing to be the problem. Thanks for you help.

I do wonder how this question was marked as resolved, because I did not mark your answer as correct because I had not tried it until now.

avatar image Alan Webster Oct 10 '16 at 06:02 PM

Steve h marked it as resolved as SkyHigh has a temporary solution (really its a bug that needs reporting and fixing)

avatar image CleanCut Oct 13 '16 at 07:10 PM

I have the exact same problem, but the workaround doesn't fix it for me. Both the original provision and the renamed one (via the workaround) show up and say valid. Selecting either one makes no difference, I get the "Provision not found..." and "Signing key not found..." errors instantly.

avatar image Richmar1 Oct 27 '16 at 10:16 PM

Thank you, Renaming And Placing Into Build/IOS/ Solved my issue!

avatar image Alan Webster Oct 10 '16 at 05:57 PM

Hi Steve, all i had to do is manually import the provision profiles using the 'Import provision' button and manually select to use the imported provision. Rather than mark the Question/problem as resolved with a workaround can you please log it as a bug to be fixed?

thanks

avatar image CleanCut Oct 13 '16 at 07:16 PM

This workaround didn't work for me, either. :-(

avatar image Alan Webster Oct 13 '16 at 07:49 PM

Hi cleancut,

This is the instructions of how it worked for me

1, download your provisioning profile from the Apple Dev site (this appears in the 'Downloads' Folder)

2, In UE4, Project Settings, Platforms, iOS click the Box to 'Import Provision' manually and select the provision in the downloads folder

3, select the recently imported Provision manually with the tick box

4, Package your project

the signing certificates work ok

avatar image CleanCut Oct 13 '16 at 10:16 PM

1, 2, and 3 are fine. I'm trying to launch on my AppleTV. With another project using 4.12.5 it works fine. With this project using 4.13.1, it just hits the two errors when I hit launch.

avatar image Aakrasia Oct 13 '16 at 10:38 PM

I removed the old provisions when I packaged, your mileage may vary, but I just thought I'd give my information.

avatar image CleanCut Oct 13 '16 at 11:50 PM

How did you remove the old provisions? I don't see any way to do it in the Editor, and the old provisions are not in the Build/IOS directory with the new one I put there as part of the workarounds.

avatar image CleanCut Oct 14 '16 at 12:16 AM
avatar image Alan Webster Oct 14 '16 at 03:12 PM

You don't appear to have the same problem as the this question, I'll comment on your question

avatar image Aakrasia Oct 14 '16 at 12:21 AM
avatar image CleanCut Oct 14 '16 at 03:57 PM

@path3tic I verified that the only profile in those locations is the one that I am trying to use. No luck. :-(

avatar image CleanCut Oct 13 '16 at 07:19 PM

Same problem here. Mac Pro 2013, OS X 10.11.6, Xcode 8.0, UE4.13.1 from the launcher.

I have tried the "rename and put in this folder and select it" workaround and the "manually import it and select it" work around. Neither changed anything. :-(

avatar image Asquires2002 Jan 19 '18 at 03:58 PM

I am having all sorts of trouble too. I have done everything possible and cant get my Provisions into UE 4.17 on MacOS 10 High Sierra. I went into my Xcode 9.2 and all my certificates and provisions are working and syncing with the Developer online account bundle ID. When I go into project settings of Unreal Engine it shows my Developer and Distribution Certificates, but my Provisions are not showing up and I don't get any green colors on either.

When I try to manually import the adhoc provision for example, the output log says "IPP ERROR: Failed to find plist in .mobileprovisions file" what is this referring too when all certificates and provisions are located in the Project/Build/IOS directory.

I have also scoured the internet and this site and still can't figure it out. I am still learning and must be missing something in UE 4.17 for this error to occur.

Hopefully someone can assist me here.

Thanks Anthony

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Let me clear up why those fail now. In Xcode 8, those are considered Managed Provisions and can not be used in the new manual signing mode, so they are being ignored during the detection of provisions during the final code sign pass by our system. The work around is as suspected to rename them or import the provision utilizing the editor. I'm working on a way to utilize them, but as they currently stand, they can't be used in a manual sign and the current thought is to detect it as valid and then make a copy of the file without the id as the file name.

more ▼

answered Oct 18 '16 at 08:31 PM

avatar image

Ravlek STAFF
1.9k 4 6 34

avatar image Alan Webster Oct 26 '16 at 07:35 PM

the problem for me is not xcode 8 i have tested the following:

xcode 7 and ue4.12 works, xcode 7 and ue4.13 Fails, xcode 8 and ue4.12 works, xcode 8 and ue4.13 Fails.

What works for me with xcode 8 and ue4.13 is to download the provision and double click it (this installs it with xcode) and then manually import and select the same provision file in to ue4.13

for me one does not work without the other. Here is a pic with the same provision shown twice top one installed with xcode, the second manually imported. alt text

using this method packed a couple of projects many times without any problems.

avatar image DennG Dec 12 '16 at 10:58 PM

Thanks for your help. Using this method Im now able to begin the launching process, but unfortunately it fails at the end with this error: https://answers.unrealengine.com/questions/536101/xcode-8-managed-provisioning-profile.html

Note: Im using a free dev account and the prov profile generated by xcode.

avatar image Steve Hardister ♦♦ STAFF Dec 13 '16 at 03:29 PM

You will need to have a paid active developer account from Apple in order to obtain certificates and provisions that will allow you to launch onto iOS devices for testing.

avatar image ocalaf Jul 08 '17 at 12:54 PM

Could you confirm that a paid active developer account from Apple is required to launch on iOS devices just for testing?

It's very curious for me that UE4 requires that paid account, I've been able to launch without problems (just for testing purposes) regular apps from Xcode, that shouldn't be different for an UE4 one, isn't it?

For me it seems like UE4 Editor doesn't handle very well this auto signing function which works perfectly just under Xcode with other iOS apps. I can understand that if you have a paid account you can just generate the proper certificate/provision manually and import them, that sounds like a nice workaround for those which have these paid iOS developer accounts.

For the other ones, like me with just a regular free apple developer account, are you saying that there's only this workaround too? Just paid 100 bucks and make it manually?

For now, all my tries failed, and just trying to make an app under Xcode with matching the name under ue4 to use these certificate/provision manually it doesn't seem to be a valid workaround, it seems to work but ends failing during the installation on the device.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question