Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaging fails when using chunks

Hey so I've been told to create a new thread regarding this. So I can't package my game when generate chunks is enabled. I'm using 4.13.1 and disabling generate chunks packages successfully. I have tried using the solution posted here but no luck.

This is the error log it put out. link text

Product Version: UE 4.13
more ▼

asked Sep 30 '16 at 06:49 PM in Packaging & Deployment

avatar image

386 16 17 22

avatar image Samantha Sutton ♦♦ STAFF Oct 06 '16 at 09:37 PM


In order to better assist you with this crash, can you verify that you're using 4.13.1? Can you upload screenshots of what your packaging process is set up like? Does this happen on blank projects too?


avatar image Mootjuh Oct 06 '16 at 10:07 PM

I'm using 4.13.1. I think the issue how I've assigned my chunks. There are some assets in one chunk relying on another chunk and I think that's causing the error, meaning it's not happening in a clean project. But All those chunks should be loaded together either way. I'm only doing this to have multiple smaller PAK files.

Here are all my packaging settings.

alt text

avatar image Samantha Sutton ♦♦ STAFF Oct 07 '16 at 04:50 PM

I am not getting this error when I package using your set up. Have you tested this in a newly created project to see if it reproduces? If it doesn't reproduce, it's likely due to how you set up your project and how they rely on one another and possibly can't be packaged that way.


avatar image Mootjuh Oct 08 '16 at 01:12 PM

Did you try assigning for example chunk ID 1 to a random material and chunk ID 2 to the texture it's referencing? I'm getting the error in a clean project with startercontent if I do just that.

"UE4Editor-UnrealEd.dll!FChunkManifestGenerator::FixupPackageDependenciesForChunks() [d:\build++ue4+release-4.13+compile\sync\engine\source\editor\unrealed\private\commandlets\chunkmanifestgene"

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Chunks are a defined sequence of packages therefore, both assets need to be in the same chunk, or a previous chunk - when you fail to do that, these issues pop up. Can you verify that you have these materials in the correct chunks?

more ▼

answered Oct 10 '16 at 08:15 PM

avatar image Mootjuh Oct 12 '16 at 05:57 PM

So I just tried reordering the chunks so the textures would be in 0, materials in 1 and meshes in 2 and on. And it worked. I didn't knew the chunk IDs had to be in order so thanks for that!

avatar image Samantha Sutton ♦♦ STAFF Oct 12 '16 at 07:47 PM

You're very welcome.

Let us know if you run into any other complications! :D

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question