x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Commandlet "looks like a commandlet"

I'm trying to run the commandlet located at https://github.com/ue4plugins/CommandletPlugin. To do this I copied it into my project as a new file however when I run the commandlet it always says "HelloWorldCommandlet looked like a commandlet, but we could not find the class." Any help would be appreciated.

 // Copyright 2015 Headcrash Industries LLC. All Rights Reserved.
 
 #pragma once
 
 #include "Commandlets/Commandlet.h"
 #include "HelloWorldCommandlet.generated.h"
 
 
 
 UCLASS()
 class UHelloWorldCommandlet
     : public UCommandlet
 {
     GENERATED_BODY()
 
 public:
 
     /** Default constructor. */
     UHelloWorldCommandlet()
     {
         IsClient = false;
         IsEditor = false;
         IsServer = false;
         LogToConsole = true;
     }
 
     ~UHelloWorldCommandlet()
     {
 
     }
 
 public:
 
     //~ UCommandlet interface
 
     virtual int32 Main(const FString& Params) override
     {
         UE_LOG(LogTemp, Display, TEXT("Hello world!"));
 
         return 0;
     }
 };
 
Product Version: UE 4.12
Tags:
more ▼

asked Oct 01 '16 at 12:29 PM in C++ Programming

avatar image

outtaspace
3 1 2 5

avatar image Jamie Dale STAFF Oct 01 '16 at 05:39 PM

What commandline are you using?

avatar image outtaspace Oct 02 '16 at 01:46 AM

I've got a .bat

"C:\Program Files\Epic Games\4.12\Engine\Binaries\Win64\UE4Editor-cmd.exe" "C:\Games\ArchV" -run=HelloWorld

that I just run in a standard command prompt on windows 7.

alt text

on a second look I wonder if it's not loading my project so it can't find the class, however if i change Argv[1] from "C:\Games\ArchV" to "C:\Games\ArchV\ArchV.uproject" it throws an error saying it can't find the map specified.

A bit of Background: I'm trying to build a script to batch import models that will run on a server. So I assume it has to run through the editor. I am also running unreal off the Epic Games Launcher. alt text alt text

commandleterror.png (103.8 kB)
log.png (55.7 kB)
error message.png (10.7 kB)
avatar image Jamie Dale STAFF Oct 02 '16 at 12:44 PM

Yeah, I was also thinking it might not be loading your project, and that does seem to be the case.

I tried this myself locally and as long as the .uproject is the first argument, it should be treated as a project rather than a map.

Is your project definitely built for the correct editor config? Bear in mind that without "-debug" on the commandline, it'll be trying to load the "Development Editor" rather than "Debug Editor"/"DebugGame Editor" build of your game.

Also, just to rule out any bat weirdness, does the same thing happen if you run that command directly in cmd?

avatar image outtaspace Oct 02 '16 at 01:02 PM

I'm relatively new to compiling the C++ in unreal. I just downloaded the launcher from epic games created a new project, added in the file I wrote above and pressed compile. I just tried setting it from development to debug in the editor and that didn't help. I also tried changing to "DebugGame Editor" in vs2015 and still ran into the same error.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Ended up downloading 4.13 from github and so far it seems to be running fine.

more ▼

answered Oct 10 '16 at 03:29 AM

avatar image

outtaspace
3 1 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question