Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

vr hands not working after packaging

I packaged my vr game using the vr template, and the hands will not grab anymore. It works fine in the editor but the packaged game doesn't work. Any suggestions?

Product Version: UE 4.13
more ▼

asked Oct 01 '16 at 03:04 PM in VR

avatar image

20 4 9 13

avatar image jimsnomis Apr 19 '17 at 09:48 AM

I have this problem as well, did you find a fix?

avatar image jimsnomis Apr 19 '17 at 10:24 AM

Figured it out, it needed mouse capture on startup from project settings

avatar image Coderandrew Apr 28 '17 at 05:44 PM

I'm having this same problem -- in packaged builds ONLY my hands don't show up and it doesn't seem that my pawn is being initialized. I'm also oriented backwards and much lower than I am in the non-packaged builds -- it seems that the VR setup config isn't being processed.

I would guess that my pawn actor isn't being created at all, but all my settings seem correct (default pawn class is set properly).

I checked and I DO have "mouse capture on startup" checked.

Does anyone have any other suggestions?

avatar image AtmaStudios Jun 25 '17 at 05:41 AM

Anybody else have this happen? I cannot get the VR Template hands to pick up objects after packaging. I have tried " mouse capture on startup" both on and off and neither seem to work. Any other ideas?

Thank you

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first

Yes, I found the cause of this problem (for me at least). The issue was that I had previously renamed/moved my GameMode class. In non-packaged builds this worked fine, but the redirector didn't function properly for the packaged build, meaning my GameMode class wasn't used, and thus my player pawn wasn't created correctly.

The solution was to "Fixup Redirectors" for the folder containing my GameMode.

more ▼

answered Jun 26 '17 at 08:37 PM

avatar image

51 1 5 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question