x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Editor sounds do not play while in PIE

Any sounds originating from the editor - such as previewing audio cues, compile sounds, PIE start/simulate (but not stop, as this is played after the PIE session is over), etc - are not audible while you are in PIE. I'm fairly certain that there isn't anything wrong with my editor/project settings, as I've come across a few other people who have this same problem. It may very well be my system audio setup, but it was working fine at one point. Nothing relevant was logged from what I could see.

Product Version: UE 4.13
Tags:
more ▼

asked Oct 01 '16 at 09:17 PM in Bug Reports

avatar image

`impulse
1 1 2 2

avatar image AndrewHurley Oct 03 '16 at 02:05 PM

Hey `impulse,

Make sure the 'Enable Sound' option within your Editor Preferences is checked and you also have 'Real Time Audio' enabled within your viewport.

Sometimes a simple restart of your Editor can address audio issues like these. I did enter a bug report last week dealing with a related issue that you might find valuable for a workaround.

UE-36540

Let me know if you have further questions or need additional assistance.

Cheers,

Andrew Hurley

avatar image `impulse Oct 03 '16 at 08:20 PM

I've tried out the workaround in the bug report you've linked, but to no avail. I've made sure that real time audio is also enabled.

Real time audio in the viewport works fine, it's the previewing of sounds (via right-click and play on a sound cue) that doesn't work while playing the game in the viewport. This also affects the start play-in-editor sound - and other similar ones like start simulate - since it's played while you're in-game.

Any audio that originates from the editor but not from the viewport/game itself seems to not play at all while you are in play-in-editor mode.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

If you have the 'Enable Sound' option on, then the sounds while in game are going to take priority over the editor. When you are PIE (playing in editor) the content browser is not the focus and is expected not to take priority when playing sounds during PIE.

You need to make sure you restart the project if you have made changes to the 'Enable Sound' option for the changes to take effect.

Thanks,

Andrew H

more ▼

answered Oct 03 '16 at 08:56 PM

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question