x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android package error after keystore info implemented

Greetings!

Okay, so I have been working on an app for a while now, and I'm more or less done. The only thing I think is remaining is getting the Distribution Signing correctly implemented. The app was packaging perfectly fine until I included the generated keystore info in the Project Settings under Distribution Signing. Now suddenly I get a build failed message.

Do know I have looked through other people's troubles here on answerhub, but haven't found any that solved this problem.

In the "Output of Keytool" field, I've filled in the path to the file the keytool generated. In my case: C:/Users/User/AppName.keytool -- I've also tried moving the file to the engine's suggested path (Project/Build/Android), with the same result.

Furthermore, the Key Alias and Key Store Password should be correct, as they are the same as I created when running the keytool.

I suspect this is an easy fix for someone more knowledgable than me, and any help will be deeply appreciated :)

Attached is a screenshot of the last part of the error message, where it seems the error is occurring: alt text

Product Version: UE 4.12
Tags:
more ▼

asked Oct 03 '16 at 11:57 AM in Packaging & Deployment

avatar image

3xist3nc3
26 2 6 9

avatar image 3xist3nc3 Oct 05 '16 at 08:44 PM

Anyone? I really need help with this.

avatar image 3xist3nc3 Oct 07 '16 at 04:17 PM

My bad, I should have included the entire error log as a text file. So here it is. Again, I really need help in solving this - both for my self and my students.

link text

error log.txt (256.7 kB)
(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hi once again, Samantha,

I am so sorry for waiting this long before answering - there's just been a lot happening. Anyway, eventually, I found out what caused the problem .. and it was a laughably easy solution:

As I wrote in the first message: "In the "Output of Keytool" field, I've filled in the path to the file the keytool generated. In my case: C:/Users/User/AppName.keytool -- I've also tried moving the file to the engine's suggested path (Project/Build/Android), with the same result."

The problem wasn't where the file was placed, but rather that I filled in the entire path to the keystore, and not only the name of the file itself. Thus, as soon as I deleted the path from the input field and kept the keystore name, it worked!

How I managed to misunderstand this is hard to fathom, but that's the reality, haha.

Thanks for your assistance :)

more ▼

answered Dec 03 '16 at 05:14 PM

avatar image

3xist3nc3
26 2 6 9

(comments are locked)
10|2000 characters needed characters left

Hey 3xist3nc3,

Please review this AnswerHub Post, your answer should be there.

Thanks!

more ▼

answered Oct 10 '16 at 08:36 PM

avatar image 3xist3nc3 Oct 11 '16 at 05:28 PM

Hi, Samantha,

a big thanks for answering! I can assure you I have read, tried and followed the instructions in that post, plus (I guess) all of the other ones dealing with just the problem I'm facing now, and to no avail. Some of what I've tried:

  • Having the .keystore file in different folders and at different locations (changing the path inside the engine accordingly), as some people have made it work by changing its location.

  • Others got it to work simply by fixing misspellings in the file's path, or added extra sets of / - or setting them in other direction. I have tried it all.

  • Some fixed the problem by changing the path inside some other file - unfortunately, I don't remember the file extension right now, and can't check - but I tried that as well.

  • I have also tried different distribution settings, different Android builds, and whatever other settings - just to see if the error message changed at all.

  • Tried deleting the Intermediate folder while UE4 was off, as I read somewhere it could potentially fix it.

Therefore, I am clueless. From what I understand of the errors, these are the trouble makers:

1) The following error occurred while executing this line: MainFrameActions: Packaging (Android (All)): D:\NVPACK\android-sdk-windows\tools\ant\build.xml:1147: Value for 'keystore' is not valid. It must resolve to a single path

2) Cannot find file D:[ PROJECTS ]\UE4 Projects\UE4 Android Projects\MeditateNOW\Intermediate/Android/APK/bin/MeditateNOW-release.apk.

Nr. 1: Yes, I think this is correct, as the .keystore is in the project folder, which should mean they're resolving to a single path (that was another one's solution).

Nr. 2: The release.apk-file it's looking for does not exist, as far as I see. Someone else on here didn't find it either, but he managed to fix the error simply by fixing some misspellings in the path name. I'm not that lucky.

Awaiting your enlightening directions :)

avatar image Samantha Sutton ♦♦ STAFF Oct 13 '16 at 08:49 PM

Delete your Intermediate and Saved folder from your project folder. Make sure that your keystore is added to YourProject/Build/Android. If it's not, please create a new one by following this documentation.

If you could upload some screenshots of your Android settings, including the keystore showing up in your folder and the SDK settings, that would be great.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question