x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE 4.13.1 Android package error

Hi.

I have been looking for a solution for this issue for a few days. And I can't figure it out. I have started a new project with the Mobile / Tablet settings as well as made it Scalable 3D or 2D. I have also tried to delete the Saved and Intermediate. I have run the Android SDK installation several times and even made sure I have the right API version for my android device. It shows up under the Launch dropdown list in UE as well. I'm using 4.13.1, I know there was some issues in 4.13. But were fixed in the latest hotfix patch.

I can pack the same project to windows just fine. But when I try to pack it to Android(ETC2) Or any other, I get the same error message.

Here is the error message I get: alt text

Product Version: UE 4.13
Tags:
more ▼

asked Oct 03 '16 at 02:43 PM in Packaging & Deployment

avatar image

AinSophAur
10 6 6 10

avatar image AinSophAur Oct 03 '16 at 02:58 PM

Additional information. I have followed the Android documentation installation guide.

avatar image AinSophAur Oct 04 '16 at 09:05 AM

By enabling both GearVR and GoogleVR seems to solve the error in the image above. But I then get a different error message.

The output log is now throwing this at me:

UATHelper: Packaging (Android (ETC2)): UnrealBuildTool: [javac] 100 errors UATHelper: Packaging (Android (ETC2)): UnrealBuildTool: [javac] 100 warnings UATHelper: Packaging (Android (ETC2)): UnrealBuildTool: UATHelper: Packaging (Android (ETC2)): UnrealBuildTool: BUILD FAILED UATHelper: Packaging (Android (ETC2)): UnrealBuildTool: P:\NVPACK\android-sdk-windows\tools\ant\build.xml:716: The following error occurred while executing this line: UATHelper: Packaging (Android (ETC2)): UnrealBuildTool: P:\NVPACK\android-sdk-windows\tools\ant\build.xml:730: Compile failed; see the compiler error output for details.

I attached the full log.link text

mobiletest.log (2.4 MB)
avatar image AinSophAur Oct 05 '16 at 12:19 PM

I am "closing" this question. Reason is that I made a fresh installation on a different computer, the android SDK setup tutorial works fine on that computer. My guess is that I have some elements on my computer that generates this issue. A type of collision between SDKs.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

A quick update and a solution to my issue. :)

I disabled the Substance plugin, and now I'm able to package the game for Android(ETC2) as well as launching the game on my mobile device, Samsung s5.

more ▼

answered Oct 06 '16 at 03:14 PM

avatar image

AinSophAur
10 6 6 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question