Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.13 Sequencer: Parameters changed in a Shot Track are resetted when the sequence finishes

4.13 Sequencer: Parameters changed in a Shot Track are resetted when the sequence finishes 0 I don't know if this is a bug or if it's intentional, but it wasn't happening before I upgraded to UE 4.13.

If I add a Level Sequence to a map and change an actor's parameter like his position for example, over 5 seconds let's say, the actor will stay at that position when the sequence is over, which is correct and expected behavior.

But if I create a second level sequence and add the first Level Sequence by dragging and dropping (a Shot Track is created), and play this second level sequence instead, then the actor's location will get resetted when the sequence is over.

I have a lot of sequences that are using other level sequences in a Shot Track, which are supposed to do a transition to gameplay, but now all the parameters changed get resetted when the sequence is finished and the gameplay is supposed to start.

top actor is what is happening, bottom actor is what I was expecting: alt text

Product Version: UE 4.13
more ▼

asked Oct 03 '16 at 07:04 PM in Bug Reports

avatar image

707 33 107 127

avatar image Matt.Williams Oct 11 '16 at 08:36 PM

Hi Ghar,

I'm having trouble reproducing this with possessable(not spawnable) static mesh and skeletal mesh actors. I'm thinking there's something I'm missing when reproducing it.

Can you reproduce this in a basic template project (Third Person Template is what I usually test in)? If you can reproduce it there, would you mind uploading it to dropbox/drive and linking it?

-Matt W.

avatar image MadisonAster Oct 11 '16 at 08:59 PM

I've had this problem as well. I tried to use sequencer to transition from one level to another using the level visibility track in 4.12. Everything would work fine right up until the end, where it would reset the levels back to their original states and so it would cut back to the original level.

I tried to work around this issue with custom events, but that didn't work, it's like sequencer takes a snapshot of the state of each actor when you start the sequence, then applies the snapshot at the end.

In my case I ended up cheating, and quickly cutting to the level just prior to starting the sequence

avatar image mettam Oct 12 '16 at 01:00 AM

I am having the same problem. Level Sequence seems to be returning to its frame zero state after it plays its duration. This was not happening in version 4.12

Can someone advise how to fix this?

I guess I could extend the duration out to a ridiculously long duration, but this seems like a bad work around.

avatar image Matt.Williams Oct 13 '16 at 06:01 PM

Hey everybody,

The only way I can help you find a workaround and enter a bug is if I can reproduce it. Can you provide more details on your setups or send an example project?

I've tried this with auto-play, GetSequencePlayer, and CreateSequencePlayer to initialize the sequence.

-Matt W.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey Guys,

I happened upon the repro for the OP's bug. I've entered UE-37338.

-Matt W.

more ▼

answered Oct 14 '16 at 04:27 PM

avatar image Ghar Oct 17 '16 at 07:05 PM

Sorry I didn't answer before, I was busy with the game jam, and then resting. I made a video displaying the issue, in case it helps. https://youtu.be/wRL-h-Pdy4U

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Reproducing the bug:

1 Create a FirstPerson example project.

2 Duplicate the example map, and open the duplicate.

3 Delete all the blocks in the map so that it looks different from the first map and save.

4 Create a new map in the content browser that's totally empty, and open it. (Because level visibilty doesn't work on PersistentLevel)

5 Open the levels window, and add the both example levels as sub-levels. Make sure they are set to load on blueprint

6 Turn off the visibility on the second sublevel.

7 Create a level sequence, add it to the level, and open it up.

8 Add a level visibility track. Create 2 hidden visibility triggers, and a second visible visibility trigger.

9 Arrange them like so:

alt text

10 Set the appropriate List item on each trigger, so that FirstPersonExampleMap2 starts hidden, and ends shown, and FirstPersonExampleMap starts shown and ends hidden.

11 Add the following nodes to the level bluprint:

alt text

12 Now hit play and you should see the FirstPersonExampleMap, then 2sec delay, then the sequence starts, then after 5 seconds or so the level visibility will switch, and all the blocks will disappear. Then when the sequence reaches the end it will switch back.

After testing the same thing with location animation, and event tracks, it appears that my bug is now isolated to the level visibility track. I'm fairly sure this wasn't the case in 4.12, but since it's working for 4.13 I don't see the need to test.

Upon watching your animation Ghar, and reviewing your post more carefully, I believe I jumped the gun. You and I are experiencing 2 separate bugs. To reproduce your bug you need to do 5 more steps:

13 Create another sequence (NewLevelSequence2), add it to the level, add an sphere to the level to animate, then add an animation track for the sphere and animate it.

14 Add a shot track, open the shot track, and add a camera.

15 Add another sequence (NewLevelSequence3), add it to the level. Then open it up and drag NewLevelSequence2 into NewLevelSequence3

16 Add a node for the NewLevelSequence3 to the level blueprint like so:

alt text

17 Hit Play and you should see the level load, 2 sec delay, NewLevelSequence3 begins playing NewLevelSequence2, Sphere moves along its path, NewLevelSequence3 ends, and 1-2 seconds later the sphere jumps back to it's starting position.

All these steps are a little complex, so here's my test project:


more ▼

answered Oct 13 '16 at 08:53 PM

avatar image

140 6 7 12

avatar image Matt.Williams Oct 14 '16 at 03:02 PM

Hey CognitionTom,

Thanks for the repro steps.

Can you please re-post this as a new thread. Sorry for the hassle, but this is not the same bug as the OP has. I was finally able to reproduce his after mulling it over and I'm entering the bug now. We need to keep your issue separate.

-Matt W.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question