x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Material + Physical Material + Surface Type = Not working.

So, I have read the various questions and answers on the answerhub about this topic. https://answers.unrealengine.com/questions/7437/question-how-to-add-footstep-sounds.html https://answers.unrealengine.com/questions/42507/palyer-movement-audio.html ...etc.

I have set my AnimBlueprint up as suggested, but it just won't actually play in the live game. The strange thing is, while inside the graph of the blueprint I can add "speed" in the default tab and it WORKS, I can hear the Sound Que firing (for the default material that is). But, when I test it in the game it does not play any sounds.

I have set up all the Physical Materials, Material Types, and updated the materials to base on the Physical Materials (which are individually keyed to types). Trace is working, anim notifies are working, sounds are set up within a Select Node, everything is set up the way the examples above describe.

Unfortunately, none of the wiki "answers" really answer anything, they just show the graphs but not the OTHER settings in the project, player, etc. I am sure this is just a simple checkbox or something, but for the life of me I cannot figure it out.

Anyone have any ideas why it would work in the BP Graph, but not in the actual game??alt text

Product Version: Not Selected
Tags:
more ▼

asked May 30 '14 at 12:32 PM in Blueprint Scripting

avatar image

GabrielDamato
136 13 15 25

avatar image GabrielDamato May 31 '14 at 05:17 PM

Has anybody had a chance to take a look at this? I am really stuck on this one...

avatar image GabrielDamato May 31 '14 at 05:56 PM

Update: It seems that the main problem was the fact that the player was using a different AnimBlueprint (which I sorted). However, this system still won't work, as it ONLY plays the sound file tagged to the DEFAULT node. It seems no matter what surface I hit, it won't recognize it so it just plays the default node sounds. Where could the break be here?

avatar image GabrielDamato Jun 02 '14 at 12:12 PM

So now I am almost certain that the break is somewhere between the Surface Type, Physical Material and the Material itself. Maybe I am not linking them together properly? This footstep sound system WORKS, but it only plays the default sound.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Scratch all of that. The line trace was tracing +Z, not -Z so it was not looking at the ground, rather it was looking up in the air.

more ▼

answered Jun 24 '14 at 03:58 PM

avatar image

GabrielDamato
136 13 15 25

avatar image MacGowss Mar 16 '16 at 04:46 AM

"The line trace was tracing +Z, not -Z"

OMG Thank you so much. I've been trying to find a solution for 3h straight...

I just changed the + Vector Z value to -500 like in this thread: https://answers.unrealengine.com/questions/7437/question-how-to-add-footstep-sounds.html

Back to project...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question