Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

can't find multiplayer sessions after adding the online Subsystem Steam


when i look for sessions without the online subsystem steam plugin it works(LAN & internet), but when i add the online subsystem steam plugin i can't find any session.

i added the ini configuration from here: https://docs.unrealengine.com/latest/INT/Programming/Online/Steam/

blueprint setup find sessions: https://gyazo.com/9285a30c8ad33970e3eb43c9540d38d7 join sessions: https://gyazo.com/82992b12feaa737f5c643161de50841e create session: https://gyazo.com/144628bbb477975a7c3045ebb060d5dc destroy session: https://gyazo.com/cbbb25cebcd7c07b020ec992a570e63e

thanks in advance,

Product Version: UE 4.13
more ▼

asked Oct 04 '16 at 03:25 PM in Blueprint Scripting

avatar image

185 44 59 82

avatar image ImVawx ♦♦ STAFF Oct 04 '16 at 03:31 PM

Hey quintendc,

A few questions:

avatar image quintendc Oct 04 '16 at 03:50 PM


i package the game in development.

i have 2 accounts and pc's on the same network.

avatar image quintendc Oct 05 '16 at 11:21 AM

here are the logs

link text

avatar image ImVawx ♦♦ STAFF Oct 05 '16 at 01:07 PM
 [2016.10.05-11.11.30:862][813]LogOnline:Warning: STEAM: Can't start an online session (Game) in state InProgress
 [2016.10.05-11.11.30:862][813]LogOnline:Warning: STEAM: Can't create more than one instance of Steam online subsystem!

It looks like you already have a session or are trying to create more than one session.

This is how I normally setup Create/Join sessions:

alt text

465502_session.png (217.5 kB)
avatar image quintendc Oct 06 '16 at 12:23 PM

still i can't join my other pc, my pc will not find any session. link text

avatar image ImVawx ♦♦ STAFF Oct 06 '16 at 12:53 PM

For some reason your the session is coming back as invalid.

Can you take a screen shot of your Blueprint that is responsible for creating and joining a session and post it here?


avatar image quintendc Oct 06 '16 at 01:03 PM

i have created a blueprint project from the launcher, and i only added the INI configuration. do i need the steamworks sdk and the module setup like here https://docs.unrealengine.com/latest/INT/Programming/Online/Steam/index.html

avatar image ImVawx ♦♦ STAFF Oct 06 '16 at 01:10 PM

You'll need to enable the SteamOnlineSubsystem. You can do this by going to Edit -> Plugins -> Online and checking OnlineSubsystemSteam on.

Complete Setup:




  • In UE4, go to Edit->Plugins

  • Select, Online Platform

  • Enable, Online Subsystem Steam

  • Restart Editor

If running a C++ Project:

Source ->GAMENAME->GAMENAME.Build.cs

Uncomment out the PrivateDependencyModuleNames.Add( ) line:

 // Uncomment if you are using online features
 // PrivateDependencyModuleNames.Add("OnlineSubsystem");
avatar image quintendc Oct 06 '16 at 02:12 PM

the blueprint is the same as the first i posted(above). when i use your INI i not able to create a session. on the create session node it returns On Failure. with my blueprint script and yours

avatar image ImVawx ♦♦ STAFF Oct 06 '16 at 02:36 PM

I just made a project to test and everything is working on my end. I am able to create and join sessions between multiple computers and users.

I suggest going through everything again and make sure you've followed all the steps required to make sessions work.

avatar image quintendc Oct 06 '16 at 02:47 PM

here are the latest logs there is somewhere a error: Error: The system cannot find the file specified.

is it possible to send me your project to test?

link text

avatar image ImVawx ♦♦ STAFF Oct 06 '16 at 03:31 PM

Here is the project.


ah500635.zip (1.2 MB)
avatar image quintendc Oct 06 '16 at 03:39 PM

i also started a new project with your ini code from above and your blueprint setup this are the logs now i can create a match but my other pc don't find it here are the logs link text

avatar image ImVawx ♦♦ STAFF Oct 06 '16 at 03:39 PM

Are you packaging your project or running from the editor?

Your logs are also showing a lot of other things going on. Much more than what I sent over. So I need to ask again, please make sure your setup is correct and not interfering with anything else.

avatar image quintendc Oct 06 '16 at 03:48 PM

this is not your project, its packaged in development

avatar image ImVawx ♦♦ STAFF Oct 06 '16 at 03:51 PM

I'm not sure what to tell you. I have given you everything you need to do in order to make this work. Take time to look at all of the instructions. Or, start a new project and build it up again with the steps I have provided or just build the project I have providing and try that.

I can't help you when every time I give you advice, you do something different or don't answer the question(s) I have asked.

avatar image quintendc Oct 06 '16 at 03:53 PM

i just tested you project but its also not working

avatar image ImVawx ♦♦ STAFF Oct 06 '16 at 03:59 PM

Please explain in every detail possible what you are doing, including buttons you're pressing, in which order. Explain how you are launching the project. What keys you are pressing, in which order, on which client. Meaning, what key are you pressing to create the session? How about what key you are pressing to join the session? How many times are you pressing each of these keys? Explain what you are seeing on the screen and give as much detail about what it's doing. As in, does the level reload? Do you see any log messages? If so, what do they say?

Take screenshots and post them to show anything that you cannot fully explain.

You will need to explain your issue with as much detail as you possibly can because I cannot reproduce your issue. Everything on my end seems to be working 100% as it should be.

avatar image quintendc Oct 06 '16 at 09:18 PM

i have started i project from scratch and tested a few things.

  • 2 Computers on 2 different networks = worked

  • 2 Computers on the same network with LAN enabled = can find match but the joining computer is not travelling

  • 2 computers connect to 2 different router 1 to home router and the other 1 router connected to home router = cant find match in LAN and internet

here is the project: https://www.dropbox.com/s/v1l14504kh6poyx/SteamOnlineProject.rar?dl=0

avatar image ImVawx ♦♦ STAFF Oct 06 '16 at 09:39 PM

So I am able to create and join a session with your project no problem:

alt text

The next step for you is to figure out why your connection is blocked. These are the ports required for listen servers:

 -URL ports
 -OnlineSubsystemSteam Port
 -OnlineSubsystemUtils.onlineBeaconHost port

You can try to open these with your router / modem, to see if that fixes the issue.

You are the first person that I have come across who has this issue. If you continue to have issues with people not being able to join, you may want to call your ISP and see if they block ports from being used.

500635_join.png (847.8 kB)
avatar image quintendc Oct 08 '16 at 12:08 AM

i tested a few things.

my friend tested the project with his 2 pc's on his network and it worked also he has the same ISP as me, but when i try it with my laptops on his network its not working

you have any idea how this is possible?

just a question: have you used 2 steam accounts for testing LAN? when i not start steam on my 2 computers i can find and join a match, when i start steam i can find the host but my pc that want's to join do no travel to it.

avatar image ImVawx ♦♦ STAFF Oct 10 '16 at 05:36 PM

I always use a different Steam account for each client, even on LAN.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

more ▼

answered Oct 18 '16 at 03:10 PM

avatar image

ImVawx ♦♦ STAFF
6.8k 114 18 128

avatar image amngomes May 28 '17 at 07:19 PM


I have a project in which I had steam sessions working using the Engine version 4.14. After some problems I updated it to version 4.16 which solved most of the problems, however I started having some problems with the multiplayer connection.

I am searching for both lan and online sessions and the client finds one lan with ping 9999, which times out when trying to join the session.

After finding this post I downloaded the ah500635 project and opened it with engine version 4.16 using the development build. The error persists.

I am using two computers on two different networks, with two different steam accounts on one I use the j key to create the session and on the other I use the k key to join the session. I get the failed to join error"

I'm using the steam id 480 since it was working on the previous version. Please let me know if this is not the correct place to post this problem.

Thanks in advance for your time.

edit: added some more information to the post.

avatar image Blackrock Jan 05 '18 at 09:43 PM

I'm stuck with the same problem, did you find a solution ?

avatar image quintendc Jan 05 '18 at 10:00 PM


i would suggest you to take a look at uworks.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question