x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Strange errors in new levels; Pawn and camera not valid

Hi all,

We've been working on a project for quite awhile and have been successfully constructing levels and logic, but recently we've been running into some very strange errors. While all of our previously made levels still work fine, when we make new levels using the SAME setup, there are elements that no longer function. Namely our system for switching character and for controlling characters no longer work. I have no idea where to start in solving this issue because as I said, the logic worked and STILL works in our old levels, but now when we make new levels the exact same logic doesn't work.

I've narrowed the issue down as best I can, and using controlling pawns as an example. I built a simple blueprint that should take control of the pawn, using the same base logic that we use for all of our pawn control. This is in a new level, and every time I hit play I get the print string telling me that the pawn is not valid.

alt text

Note: This pawn works fine in our older levels, and using a different pawn in this same level yields the same result, and the pawn is "not valid". Cameras yield similar results, showing as "not valid".

This problem began when we were using 4.12.5 and upgrading to 4.13.1 has had no effect. We use P4V for source control, if that could make any difference.

Any ideas what would be causing this issue? Let me know what other information I can provide in solving this issue, it's been a real shot in the foot for development and I'm stumped.

Thanks for reading!

-Nick

Product Version: UE 4.13
Tags:
pawn not valid.png (186.0 kB)
more ▼

asked Oct 04 '16 at 05:00 PM in Blueprint Scripting

avatar image

nickjborn
23 3 7

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Problem solved; the folder that we were making new levels in contained parenthesis, which apparently was causing the issue. Remove those made everything work perfectly again.

more ▼

answered Oct 06 '16 at 06:22 PM

avatar image

nickjborn
23 3 7

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question