x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

UMG Widget Textures not updating/bug

Hello there, I have hit a wall and it just seems my unreal engine is acting very strangely. I have the Action RPG Inventory System from the market place and created a crafting system on the side. If I hard code each crafting slot I can make it work fine, but for re-usability and and future updates, I decided to make a data list of craftable items and to use methods from the inventory system to use the data list to update the crafting "inventory" window.

I have for the crafting window to populate with "craftSlots" and there is a binding to a crafting structure icon to update the texture from the data list item. This doesn't work (although the blueprint is exactly the same as the inventory system) the items remain blank and the umg widget doesn't register the variable change to update the texture (I have done debugging and the variable in the array is changing as it should it just isn't updating).

alt text Craft Array initialization

alt text Populate the crafting window with craft slots

alt text Shows populated crafting window

alt text Shows the texture bind to Craft item info Icon

alt text In the inventory manager, this function runs during initialization and the aim is to set items in the inventory from the data list (in this case there is only one item in the data list, so the first item in the inventory should change the rest blank). All items in the inventory are still blank like the above picture.

Product Version: UE 4.12
Tags:
1.jpg (424.3 kB)
2.jpg (456.1 kB)
3.jpg (402.0 kB)
4.jpg (376.2 kB)
5.jpg (428.9 kB)
more ▼

asked Oct 05 '16 at 03:20 AM in Blueprint Scripting

avatar image

Scottc91
139 18 19 26

avatar image Scottc91 Oct 05 '16 at 03:30 AM

alt text I change the binding to a function that makes a new slate object using a variable "Icon" Still doesn't work using the method above and changing the set variable to Icon and breaking the craft item info and plugging in icon.

alt text I tested out setting every item in the array to the same Icon value.

alt text As you can see it changes the textures to all icons as expected.....

alt text As that worked... I decided I would set the first array item only.

alt text Error....

Any ideas what is going on? I don't understand why the binding directly to the Craft Info Item Icon isn't updating in the first place.. then it is just strange that I can set all array icons, but it won't let me set one array item?

6.jpg (372.7 kB)
8.jpg (433.3 kB)
8a.jpg (415.8 kB)
7.jpg (403.7 kB)
7a.jpg (417.1 kB)
avatar image Rudy Q ♦♦ STAFF Oct 05 '16 at 01:47 PM

Hello Scottc91,

I have a couple of questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue in a clean project?

avatar image Scottc91 Oct 05 '16 at 02:08 PM

I haven't tried a new project because there is a log of blueprints involved and recreating them all would take a long time. I literally used the Inventory RPG Inventory system and duplicated the code to use on my own crafting window. For some reason the UMG widget variable "Craft Item Info" isn't communicating with Inventory Manager Component. Then being able to set all the images in the array, but not able to set just one seems very strange.

I'll give it ago when I get home later

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Scottc91,

I noticed that you mentioned giving the reproduction steps another go. We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

Thanks,

more ▼

answered Oct 10 '16 at 06:14 PM

avatar image

Rudy Q ♦♦ STAFF
47.4k 545 132 524

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question