x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

No ambient occlusion in VR

So I have no visible ambient occlusion in projects created with the Virtual Reality template. My screen is completely white in buffer visualization (Ambient occlusion).

I tried: - adding post processing volumes with the ambient occlusion cranked up - going to project settings -> rendering -> enabled ambient occlusion & ambient occlusion static fraction - export project setting from another project with AO working (for example the First person shooter template) and importing it into my virtual reality project - baking my light with and without light reflection capture (which shouldn't make a difference, but who knows)

Also I'm using version 4.13.1 and I have the same problem on different PC's in different projects all created with the VR template

https://forums.unrealengine.com/showthread.php?124974-No-ambient-occlusion-in-VR!-(Virtual-reality-teplate-project)&p=604734#post604734

alt text

Product Version: UE 4.13
Tags:
more ▼

asked Oct 05 '16 at 09:04 PM in Rendering

avatar image

Elias Leonard
6 1 3 5

avatar image Night Watcher Oct 06 '16 at 12:27 AM

That's strange, I know that AO is heavy for VR and is disabled by default, but I don't know why it is not working after enabling it manually in the postprocess effect. Try setting the post process volume to unbound?

avatar image Elias Leonard Oct 07 '16 at 07:45 AM

No, doesn't work :/ Also tried setting AO to true in the .ini files and using a command line in the console to enable it. But nothing worked.

You can check out this thread https://forums.unrealengine.com/showthread.php?124974-No-ambient-occlusion-in-VR!-(Virtual-reality-teplate-project)

avatar image Jonas_Molgaard Oct 27 '17 at 11:25 AM

Did you find the answer to this? Im trying to get a nicely lit environment with Static Skylight and Stationary Directional light as suggested by a lot of people, problem is that it looks very flat, especially in areas (indoor) where there are primarely indirect light, so i thought i could soften it up with baked AO... but no matter what i've done so far, i get the same white screen as you. I've searched for some good examples, and people that has it working, has showed results, but not how they got to those results. So im hoping someone would be so kind to post a working project which show how to set it up properly.

avatar image Elias Leonard Oct 27 '17 at 11:47 AM

no, it's a long time ago, but i know it was turned off in some text file from the project. So if you dig deep you can actually turn it on again if you want to dig in the code. But be careful because i know my project crashed when I did that so maybe it's turned off for a good reason. Maybe they already updated it since then, don't know :s sorry man.

avatar image Jonas_Molgaard Oct 27 '17 at 11:50 AM

hmm, so if i understand you correct, you had to make an engine ini change in order for these settings to have any effect?

avatar image Elias Leonard Oct 27 '17 at 11:54 AM

yes correct, I turned it on everywhere i could. So project setting etc etc but since that didn't do anything I went into some text file (the .ini that was probably) and turned it on in that as well. Let me know if it worked for you. I know it caused some crashes with me so I just turned it off again :/

avatar image 6r0m Oct 27 '17 at 12:48 PM

all of this commands enabled ? alt text

53410cd6aa.jpg (379.0 kB)
avatar image Elias Leonard Oct 27 '17 at 12:53 PM

jup and if i remember correctly, it didn't work for me if i did it with a command. I really had to change it manually in some files

avatar image 6r0m Oct 27 '17 at 01:05 PM

just check what is exactly off

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Are you using forward rendering? If so, AO is not supported.

more ▼

answered Nov 01 '17 at 02:55 PM

avatar image

rfellers
1

avatar image Elias Leonard Nov 02 '17 at 08:33 AM

pfff sorry really can't remember if we used forward or deferred. My best gues is forward so that could explain the crash as well when i forced the AO on

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question