x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

GearVR app crash at Open Level

I am trying to build simple aplication for GearVR with two maps ("Empty" and "Aran_Test"). The first map is loaded at startup and it works fine. But when I want to move to the second map via Open Level node, my app crashes and Oculus Home default map is loaded. Both maps are included in Project Settings "List of maps included in package build", the first map is set as default map for game. All Android settings are set correctly (I hope so), because I have already built working app for GearVR.

The best part is, that the crash occurs randomly. Sometimes my second level is loaded correcly but mostly - it is not. When I run my app via "Developer Mode" from GearVR Service from Android, it works fine.

Here is the crash moment from my log: log.txt

Why this Open Level does not work every time?

alt text

Product Version: UE 4.13
Tags:
gearvr_log.txt (3.6 kB)
more ▼

asked Oct 06 '16 at 08:30 PM in Packaging & Deployment

avatar image

Koralgoll
405 16 24 44

avatar image Rayen1990 Oct 07 '16 at 12:10 PM

Hi, we have the same problem :/. When I run app with gearvr developer mode on, it crash. When I run app in real gearvr headset it crash. It doesn't crash only when I run app with gearvr developer mode on, and click task manager on my device and return back to the game. (it crash on new created project (4.13.1))

avatar image CarlosCoronado Oct 19 '16 at 06:17 PM

Same problem here!

Also tried with console command "Open MapName" But it shows the exact same behaviour.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Koralgoll,

UE-36903 is already entered for this issue. It's currently unresolved but we're working diligently to resolve the issue as soon as possible.

Thanks!

more ▼

answered Oct 12 '16 at 08:00 PM

avatar image Bamwd5 Dec 21 '16 at 04:08 AM

Any news on this Samantha? We are too awaiting a fix for this issue.

Thanks, Brad

avatar image Samantha Sutton ♦♦ STAFF Dec 21 '16 at 09:42 PM

Bamwd5,

This could not be reproduced in 4.14. Are you still seeing this happen in 4.14? If so, please submit a new post to AnswerHub and provide reproduction steps with additional details. Add the link to this thread as well, just so that we can reference it.

Thank you!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question