x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.13] FBX foliage unpaintable

Import any mesh into 4.13.0 or 4.13.1 and try to paint any mesh on it with the foliage paint tool. Test against any mesh imported before 4.13

  1. Make cube in maya scale to be large

  2. export as fbx import cube in unreal

  3. 4.13 make new level add cube to level select foliage tool, add any

  4. mesh to foliage tool try to paint on

  5. cube, paint brush size sphere will not show up on imported geo

  6. Now open up 4.12.5

  7. import same cube

  8. painting works

I should add the auto snap of placing meshes to the surface of other meshes from the content browser also doesn't work. Probably the same thing.

Product Version: UE 4.13
Tags:
more ▼

asked Oct 06 '16 at 11:06 PM in Bug Reports

avatar image

daveSchoneveld
16 1 5 8

avatar image Adam Davis STAFF Oct 07 '16 at 01:43 PM

Hi daveSchoneveld,

Unfortunately I have not been able to reproduce this error on my end with the steps provided. What is the exact size of the object you are importing? Additionally, does this occur with any modeling program or only from Maya?

avatar image daveSchoneveld Oct 07 '16 at 02:45 PM

Size doesn't matter but if you made a cube in maya its default is 1cm so I said scale it up. If I import any FBX into 4.13 it is un-paintable, un-snapable. If the object was there from 4.12 it works fine. If I reimport one of those objects that worked fine in 4.12 into 4.13 where its working b/c it was there from 4.12 it will stop working.

So you tested it and it works for you? Hmm, it didn't work in 4.13.0 nor 4.13.1 I don't think a reinstall is the solution but I can make a video of the issue if that would help.

avatar image daveSchoneveld Oct 07 '16 at 03:06 PM
avatar image Adam Davis STAFF Oct 07 '16 at 03:20 PM

This is the FBX I have used to attempt to reproduce this. The asset itself was created in Blender. Can you check on your end and see if it works for you. If it does, the error may be from Maya exporting or it could be a collision error with either the mesh or the foliage tool.

link text

untitled.zip (3.9 kB)
avatar image daveSchoneveld Oct 07 '16 at 03:48 PM

That doesn't work for me either.

avatar image daveSchoneveld Oct 07 '16 at 04:11 PM

Tried uninstalling 4.13 and re-downloading and reinstalling (of course via the launcher) that didn't fix anything.

avatar image daveSchoneveld Oct 07 '16 at 04:28 PM

My GeForce Driver is latest 373.06 on a 970 I have SteamVR running (can't imagine that affects things) Tried other combinations of settings on import, nothing changed the paintablility. just trying to think of why it works for you and not for me.

avatar image Adam Davis STAFF Oct 07 '16 at 06:19 PM

Try turning off SteamVR and any additional plugins. I don't think this will be the cause of the error, but it is good to go ahead and remove the possibility. Additionally, can you show me a screenshot of your foliage painting details pane?

avatar image daveSchoneveld Oct 07 '16 at 08:30 PM

alt text

detailfoliage.jpg (90.5 kB)
avatar image Adam Davis STAFF Oct 07 '16 at 09:41 PM

Unfortunately I haven't been able to reproduce this on my end. Try unchecking then rechecking the "Static Meshes" check box. Additionally, ensure your imported asset has collision.

avatar image daveSchoneveld Oct 07 '16 at 09:48 PM

but you don't need collision on to be able to paint on the objects. Still, I tried checking unchecking box, still broken, Is there a user settings file I can delete? or something to cleaer wipe my settings to make sure I didn't break the settings somewhere? I just uninstalled 4.13 again, this time deleted folder in C: I see the launcher has some settings, do I need to delete anything in there?

avatar image Adam Davis STAFF Oct 07 '16 at 10:27 PM

Try removing the intermediate and saved files within your project folder. If you go to \Unreal Projects\PROJECTNAME\ you should see them and these can safely be removed, leaving the content, config, and uproject files. Please let me know if this resolves the error.

avatar image daveSchoneveld Oct 07 '16 at 11:01 PM

I started a new project I don't need any files. I can blow the whole project away. That can't possibly be the solution. I know you're trying to help, and thank you! Its frustrating dealing with bugs esp ones that are not easily reproducible, so again thanks for your time and patience.

As I demonstrated in the video it works in 4.12.5, and the exact same steps do not work in 4.13.1. If its a config file where is the reset? If I uninstalled and reinstalled is there any remnant files that can corrupt the reinstall? Are the saved editor settings in the launchers ini (C:\Program Files\Unreal Engine\Launcher\Engine\Config)? or in a folder outside the install directory?

I uninstalled 4.13 deleted the 4.13 folder in the programs directory. Reinstalled via launcher. New project, import your fbx. Nope. Still cannot import any fbx and paint foliage tool on it. Also cannot drop objects in a level and have them snap to imported fbx's. like place an object ontop of the box, it will snap to the floor not the box, like it would in previous versions of unreal. Its clearly an issue with the editor. Its having trouble ray casting on the visibility of objects. It has to be an engine/editor issue.

You are not have this problem at all? Could you have someone else test it quickly? Watch my video and confirm it works for them? I feel like you're out of ideas like I was before even posting to here. I've spend a number of hours over 2 days trying to trouble shoot this issue for every angle I can think of. Its a show stopper. I need it working. Is there anything else we can try? Another person who might have other ideas to try?

avatar image daveSchoneveld Oct 07 '16 at 11:25 PM

I think this is more clearly the issue: https://www.youtube.com/watch?v=mOWaJGaI2-Q not the foliage tool but the FBX import is broken as I demo in the video.

avatar image Adam Davis STAFF Oct 10 '16 at 02:26 PM

Try re-checking auto-generate collision. I was able to reproduce this, but only when the collision is turned off upon import. Turning on collision resolved the error.

avatar image daveSchoneveld Oct 10 '16 at 02:59 PM

Good news, you are correct that is a work around, however the bug exists. Auto generate collision is not the solution. In most companies you can't have the turned on. So someone changed something on the FBX import, and it needs to be rolled back to 4.12's import. I want to control collisions very specifically. As in specifically NOT have collisions on objects I don't want them to. I don't want to auto generate collisions just so they can be paintable, just like it worked in 4.12

avatar image daveSchoneveld Oct 10 '16 at 03:01 PM

Also collisions are not needed for this to work. Import with auto generate collisions then delete the collision and it still works.

avatar image vincent312 Oct 10 '16 at 08:57 AM

I meet the same problem, all the mesh in the level can not be painted

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I believe there was a misunderstanding, I apologize for the miscommunication. I was asking you to check this to ensure we were seeing the same error and that I wasn't missing something. I have reproduced this error and have entered a bug report here. You can track the report's status as the issue is reviewed by our development staff.

more ▼

answered Oct 11 '16 at 02:49 PM

avatar image daveSchoneveld Oct 17 '16 at 04:36 PM

Just to be clear this is not a foliage bug but a object surface bug. You cannot snap object to the surface of the imported object either, the same way the paint tool will also not be able to "see" the object surface.

avatar image JackP STAFF Oct 21 '16 at 09:26 AM

Several editor tools use visibility collision to determine where mesh surfaces are including snap to surface and foliage painting.

I believe there has been a change in behavior for the case where the Auto Generate Collision checkbox is not set. In version 4.12 the imported static mesh still has a collision model based on the triangles even if you don't set the checkbox.

This can be seen in the Static Mesh viewer with the Collision button pressed. In 4.12 you can see the collision triangles but in 4.13 there is absolutely no collision. You can also see this in the editor viewport with the Visibility Collision view mode. In 4.13 the reimported mesh doesn't show up, but in 4.12 it does.

4.12 (checkbox unchecked) 4.13 (checkbox unchecked)

412_unchecked.png (256.8 kB)
413_unchecked.png (391.6 kB)
avatar image John Alcatraz Nov 18 '16 at 07:19 AM

Hey Jack, not related to this exact bug but to foliage, do you know something about this HISMC bug that's currently in master it seems? :) https://answers.unrealengine.com/questions/525398/hismc-bug-always-show-lowest-lod.html

avatar image Sean L ♦♦ STAFF Nov 18 '16 at 04:28 PM

Hey John,

Please create a new thread if you are experiencing a separate issue so we can investigate it as such.

Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question