x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

PIE Multiplayer Dedicated Server replication problems

Hello,

I'm testing my multiplayer game in the editor, using the "Dedicated Server" option. When I test with just one client, things work as expected. Whenever I test with more than one client, however, I see weird behavior.

Here's a video of the behavior: https://youtu.be/MGt0zRqgTvE

Things that are not working as expected when using more than one client: -The CameraRigRail, and its CineCameraActor, do move along the side of the track as they should. And the camera's rotation goes haywire. -The actual player characters do not move. The bots move, but the actual clients do not. I've put the movement code inside of the character's Tick method, and it's using AddMovementInput(as you can see at the end of the video). The bots and the actual players are using the same character.

Any ideas on why this is happening?

Product Version: UE 4.13
Tags:
more ▼

asked Oct 07 '16 at 08:03 PM in C++ Programming

avatar image

Nimgoble
31 1 3 8

avatar image MacDx Oct 07 '16 at 11:20 PM

Can you show with screenshots some of your blueprint logic?

avatar image Nimgoble Oct 07 '16 at 11:21 PM

It's not in blueprints. It's in C++

avatar image Nimgoble Oct 09 '16 at 05:35 AM

It's being caused by a Level Sequence. I'm triggering a level sequence in the level blueprint's BeginPlay event. After the level sequence is over, the player controllers are being destroyed on the client, for some reason.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

This was due to my player controller having a Multicast UFUNCTION.

more ▼

answered Oct 10 '16 at 08:40 PM

avatar image

Nimgoble
31 1 3 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question