x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Dedicated server only hosts one valid player

Hey guys,

Today I come with an interesting question.... (interesting to me)

I am doing a multiplayer game and I'm having the following issue: - After packaging and running the server, I get only one valid player according to the game mode. That is, the first player to join gets his loadout (in my settings, the custom Character, HUD, Gamestate etc. Every other player that joins does not get that though.

However whenever I close the session in the server Log I still get that my custom Controller that I assigned so I am really not understanding.

These are my Game Mode settings: http://puu.sh/rCCPI/89f019c1ca.png http://puu.sh/rCCUw/55ac21f8f1.png

I get no warnings nor anything whenever joining the server. Furthermore, Something that I also notice is that I get a spectator pawn automatically assigned to me.

How can I fix this? What to I need to do?

Thanks

Product Version: UE 4.12
Tags:
more ▼

asked Oct 09 '16 at 04:49 AM in Packaging & Deployment

avatar image

me4dinosaur
251 15 14 20

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Never mind I got it solved. In Game Mode, make sure that you untick start as spectators in default options.

more ▼

answered Oct 09 '16 at 05:27 AM

avatar image

me4dinosaur
251 15 14 20

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question