x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Character won't move after changing GameMode

Hello, So, here is my problem. So I created a new GameMode for my game so all characters would spawn as the same character. I went into the world settings and changed the GameMode overwrite to the GameMode I created. It worked...mostly. All characters spawned as the same character, but I lost the ability to move any of the characters. I used to be able to walk, crouch, and sprint, but now I can't even move the character. Anybody know why its not working?

Product Version: UE 4.13
Tags:
more ▼

asked Oct 11 '16 at 11:52 PM in Blueprint Scripting

avatar image

Dark_Shadow_12
13 7 6 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Dark_Shadow_12,

In the new GameMode blueprint>Details>Classes: you need to set your pawn class here. Once that is set, you have to select the Animblueprint that contains the State Machine which triggers these animations in the CharacterBlueprint>(select) mesh>details.

Let me know if this does not answer your question.

Steve H.

more ▼

answered Oct 12 '16 at 07:31 PM

avatar image Dark_Shadow_12 Oct 12 '16 at 10:42 PM

Still didn't work. I set the default pawn and set the animation blueprint in the CharacterBP. Any other fixes? Also, could you send pictures with your answers? That would help a lot.

avatar image Steve Hardister ♦♦ STAFF Oct 13 '16 at 02:38 PM
  1. Make sure your Character is using the AnimBlueprint with the state machine already set up:

  2. CharBP/AnimBP

  3. AnimBP Detail

3.Make sure you have not deleted your Inputs in Project Settings>Inputs (You should have Axis settings like Move Forward, Move Right and Action Settings like Space = Jump, C = Crouch): 4. InputSettings 5. Finally, Make sure you have chosen your Game Mode in the World Settings at: WorldSettings/GameMode 6. The following picture shows the Character Blueprint selected in the New GameMode Blueprint:

  1. GameMode/SelectCharacter

2selectanimbp.png (496.5 kB)
3engineinput.png (179.0 kB)
4animbpdetail.png (394.9 kB)
5gamemode.png (689.1 kB)
1gamemode.png (206.1 kB)
avatar image Dark_Shadow_12 Oct 14 '16 at 12:25 AM

Thanks. I changed the settings on the gamemode and got it to work.. I really appreciate the help :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question