x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Bug Report] Add to Array doesn't work through Custom Event

Hi there!

I'm not sure if this is a bug or even intentional (I hope not though).

I'm trying to re-use a large piece of code multiple times each time with different inputs and thought I could do that with a Custom Event, however adding to an array, which is what I need, doesn't seem to work correctly..

alt text

As you can see the Custom Event should take in two variables. The first input is "CustomExtends" and works without a problem but the second one "AbsoluteExtends" which is an Array of vectors doesn't seem to work. (the right picture shows the Custom Event, I have not connected the Absolute Extends to the add node because doesn't work)..

Apparently it's not possible to add new elements to that Array when going through the Custom Event.

I tried and found it possible when "setting" the Array at the beginning of the custom event but this would defy the whole purpose of using the CustomEvent in the first place..

  • Is this a Bug? Or is it just not possible to directly add new elements to an array through a Custom Event?

Thanks a lot for your answer,
Kind Regards!

Product Version: UE 4.13
Tags:
arraybug.png (771.6 kB)
more ▼

asked Oct 12 '16 at 07:28 AM in Bug Reports

avatar image

OpenStringStudio
133 31 30 34

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey GullJemonStudios-

What appears to be happening is the custom event is receiving a copy of the array data rather than a pointer to the array itself. This behavior has been reported here: https://issues.unrealengine.com/issue/UE-37202 . As you pointed out, using the array itself in place of the event node's input pin will update the array as expected. Another workaround would be to create a function in place of a custom event which will update the passed in array directly from the function input node pin.

Cheers

Doug Wilson

more ▼

answered Oct 12 '16 at 01:59 PM

avatar image OpenStringStudio Oct 13 '16 at 08:18 AM

Okay, thanks for your info! I placed my vote already.

If your interested: What I wanted to do is to use this custom event for multiple different arrays like "AbsoluteExtends(0), (1), (2) etc.. at multiple locations.

That way I could have reuse all add-nodes, make it a lot more user friendly and spare myself a lot of tedious work, connecting the arrays with the corresponding add-nodes and such.. Hope you understand now.. but I guess there's not much one can do about this until it has been fixed, right?

Thanks again for your help!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question