x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Deferred decal will not work on Unlit material.

I've created a decal material that correctly renders on a Default Lit material. However, it does not render on an Unlit material. I can't think of a reason why this wouldn't work, so I'm guessing it's a bug. All of my materials are unlit in my stylized game, and it seems brutal that I can't use decals at all.

Any help is appreciated. Thank you!

alt text

Product Version: Not Selected
Tags:
decal_composite.jpg (153.4 kB)
more ▼

asked May 31 '14 at 08:52 PM in Rendering

avatar image

lackthereof0
267 11 23 27

avatar image lucabelluccini Aug 02 '15 at 09:54 AM

I have the same issue on a Transparent material. It is not rendered at all.

Testing further... The decal visibility is coupled with the Rendering properties of the object where the decal is projected on.

I tried to set the flag "Hidden in game" and decals are no more working

avatar image TJ V ♦♦ STAFF Aug 03 '15 at 01:13 PM

Hi lucabelluccini,

Could you post this as a new report in the Rendering section? Make sure to include screenshots of your setup and the results that you're getting.

Thanks,

TJ

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi lackthereof0,

Thank you for the feedback. This is a known issue that our developers are currently looking into.

Thanks, TJ

more ▼

answered May 31 '14 at 09:28 PM

avatar image

TJ V ♦♦ STAFF
41.1k 1009 183 493

avatar image Litruv May 28 '15 at 11:30 AM

This ever get solved ?

avatar image TJ V ♦♦ STAFF May 28 '15 at 07:56 PM

Hi Litruv,

Yeah, I just tested this in version 4.7.6 of the editor and it is working correctly now.

Cheers,

TJ

avatar image PhilipRamirez Jul 02 '15 at 06:17 PM

Hello TJ, don't mean to be too annoying or anything but I'm having this issue on 4.8. It would be great if you could take a look into this again!

Here's my question

avatar image TorQueMoD Feb 13 '16 at 03:26 PM

I'm working in 4.8 and its still not fixed. Is there something you have to do to get the decal to work properly?

avatar image TJ V ♦♦ STAFF Feb 16 '16 at 07:46 PM

Hi TorQueMoD,

Basically just the steps that the OP mentioned in the original report. If you still aren't able to get this working, feel free to post screenshots and a description of your setup.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question