x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Android Package Failed (Build.xml does not exist)

Like the title says, I've been trying to package the FPS blueprint template for android in development mode, and it comes back with "Build.xml does not exist" every time. It also says directly afterward that it could not find the [projectname] -debug.apk file. I'm running 4.13 and I just recently uninstalled all the android codeworks and reinstalled it with the one from in the engine extras folder. I have visual studio 2015 installed, but I've tried it with 2013 as well, and the errors were the same. I also made sure to set my environment variables correctly as you can see from the picture. (Disregard my use of the D:/ Programs folder to install the sdk and ndk, I just forgot to create the NVPACK folder upon intallation)

Been working on this for 2 weeks now with no success. I need it to work for a class project. With love to everything that is good, please tell me what I'm doing wrong.

alt text

Here is the output log as it fails...

UATHelper: Packaging (Android (ETC1)): ====10/12/2016 1:37:34 AM====PERFORMING FINAL APK PACKAGE OPERATION================================================ UATHelper: Packaging (Android (ETC1)): UEDeployAndroid.RunCommandLineProgramAndReturnResult: Making .apk with Ant... (note: it's safe to ignore javac obsolete warnings) UATHelper: Packaging (Android (ETC1)): Buildfile: build.xml does not exist! UATHelper: Packaging (Android (ETC1)): Build failed UATHelper: Packaging (Android (ETC1)): UEDeployAndroid.RunCommandLineProgramAndReturnResult: Making .apk with Ant again to show errors UATHelper: Packaging (Android (ETC1)): Buildfile: build.xml does not exist! UATHelper: Packaging (Android (ETC1)): Build failed UATHelper: Packaging (Android (ETC1)): Program.Main: ERROR: AutomationTool terminated with exception: System.IO.DirectoryNotFoundException: Could not find a part of the path 'E:\377\TESTPROJECT\Intermediate/Android/APK/bin/TESTPROJECT-debug.apk'. UATHelper: Packaging (Android (ETC1)): at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) UATHelper: Packaging (Android (ETC1)): at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost) UATHelper: Packaging (Android (ETC1)): at UnrealBuildTool.UEDeployAndroid.MakeApk(AndroidToolChain ToolChain, String ProjectName, String ProjectDirectory, String OutputPath, String EngineDirectory, Boolean bForDistribution, String CookFlavor, Boolean bMakeSeparateApks, Boolean bIncrementalPackage, Boolean bDisallowPackagingDataInApk) UATHelper: Packaging (Android (ETC1)): at UnrealBuildTool.UEDeployAndroid.PrepForUATPackageOrDeploy(Fi UATHelper: Packaging (Android (ETC1)): leReference ProjectFile, String ProjectName, String ProjectDirectory, String ExecutablePath, String EngineDirectory, Boolean bForDistribution, String CookFlavor, Boolean bIsDataDeploy) UATHelper: Packaging (Android (ETC1)): at AndroidPlatform.Package(ProjectParams Params, DeploymentContext SC, Int32 WorkingCL) UATHelper: Packaging (Android (ETC1)): at Project.Package(ProjectParams Params, Int32 WorkingCL) UATHelper: Packaging (Android (ETC1)): at BuildCookRun.DoBuildCookRun(ProjectParams Params) UATHelper: Packaging (Android (ETC1)): at AutomationTool.BuildCommand.Execute() UATHelper: Packaging (Android (ETC1)): at AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands) UATHelper: Packaging (Android (ETC1)): at AutomationTool.Automation.Process(String[] Arguments) UATHelper: Packaging (Android (ETC1)): at AutomationTool.Program.MainProc(Object Param) UATHelper: Packaging (Android (ETC1)): at AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param) UATHelper: Packaging (Android (ETC1)): at AutomationTool.Program.Main() UATHelper: Packaging (Android (ETC1)): Program.Main: AutomationTool exiting with ExitCode=1 (Error_Unknown) UATHelper: Packaging (Android (ETC1)): BUILD FAILED PackagingResults:Error: Error Unknown Error

Product Version: UE 4.13
Tags:
more ▼

asked Oct 12 '16 at 08:59 AM in Packaging & Deployment

avatar image

Trynn
56 3 5 7

avatar image Trynn Oct 13 '16 at 03:56 PM

Still having this issue. Working on running full installation process on another computer to try and package the game from it. Will update after I get a chance to try packaging.

avatar image Samantha Sutton ♦♦ STAFF Oct 13 '16 at 09:32 PM

Trynn,

  • Did you install the SDK Platform for API-19?

  • Have you tried deleting your Intermediate and Saved folders from your project?

  • Does this happen on newly created projects?

Thanks!

avatar image Trynn Oct 14 '16 at 02:18 AM

Sorry I'm on my phone, I forgot to click the reply button before commenting last time. Thank you for he reply!

To answer your questions

Yes I installed API 19

Yes i deleted those folders and tried that.

And yes it happens with a brand new empty blueprint project.

avatar image Trynn Oct 14 '16 at 07:37 PM

10/14/16 Update - I opened a new project after installing all of android codeworks on a new computer and tried to package from there. I was successful on the first try! I'm literally blown away right now. I don't know why my laptop won't package. I'm going to now try packaging my game project to see if it will package. I will update with results.

avatar image Trynn Oct 14 '16 at 02:15 AM

Yes I installed API 19.

Yes I deleted the folders and tried that as well.

And yes it happens with a brand new blueprint template project, not just with my game project.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Okay, so I am proud to say, I figured it out! I packaged my game project to ETC1 for Android on my desktop and it worked perfectly. The only thing I can think of that is different about the computers is that I installed the Codeworks software on the C drive at the initial path it chooses when you run the install. On my laptop, I had put it in a different location. I don't know what else could have been the problem. I'm going to try re installing all the codeworks software on my laptop and try it from there to find out if that fixes it. If all goes well I will repost as an answer to this problem.

more ▼

answered Oct 14 '16 at 07:59 PM

avatar image

Trynn
56 3 5 7

avatar image Samantha Sutton ♦♦ STAFF Oct 14 '16 at 08:17 PM

I'm glad that you've resolved the issue. If you happen to run into a new issue, or locate a bug - please create a new AnswerHub post and provide as much information as you can. :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question