x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Anim Trail not rendering in Android Mobile!?

Dear Unreal,

Recently i've come into a problem that my anim trail is not working in my mobile Note 7. I package using OPEN GL3.1 settings and i can't get the anim trail to be render when launch in mobile, when in editor and PIE everything is okay. Please advise which solution can i try? i tried finding everything in materials, particles but settings are good to go. Have no clue why after package and install in android doesn't show up.

Product Version: UE 4.13
Tags:
more ▼

asked Oct 12 '16 at 03:05 PM in Packaging & Deployment

avatar image

dizzynoob
101 4 11 14

avatar image dizzynoob Oct 12 '16 at 03:55 PM

Okay. I tried on Packaging using Open GL ES2 for android then trail is working. Does this means OpenGL ES3.1 doesn't support? Please advise soonest is this a bug?

avatar image dizzynoob Oct 15 '16 at 12:58 PM

Dear unreal community. Is this a bug for Packaging es3.1 for anim trail? Please advise as I Package es2.5 everything works but not in es3.1 Packaging. Please advise and check soonest.

avatar image dizzynoob Oct 21 '16 at 01:26 PM

Dear Unreal Engine,

Is this a bug in 4.13? please advise ASAP as we're currently stuck here. Package in ES 3.1 doesn't show trail but in ES2.5 is okay. Please advise.

avatar image Tim Hobson ♦♦ STAFF Oct 31 '16 at 09:31 PM

Hi Dizzy,

When I try an openGL 3.1 build on S7 Edge I don't get an issue that I can see. I get consistent results in both the editor and device.

Can you put together a sample project that demonstrates your issue and I can have a look to see if there is something there. I just used a default third person character with the trail triggered on the walk animation.

-Tim

avatar image dizzynoob Nov 01 '16 at 07:18 AM

Dear Tim,

I believe it might be the Note 7 issue. Since this phone is no longer continue, i guess it's not a big problem =)

avatar image dizzynoob Nov 12 '16 at 08:55 AM

Hi Tim,

I tried on S7 Edge still no luck, using 4.14 preview 3 now, trail not showing in Package ES3.1 but show on ES2. Let me get some screenshot on the materials and the particles, as well as some gameplay of the game in mobile...

avatar image dizzynoob Nov 20 '16 at 04:43 PM

This is the material setup. things are okay in ES2, but i tried again package to ES3.1 problem again, editor works great.

trailmat.jpg (627.2 kB)
(comments are locked)
10|2000 characters needed characters left

-1 answers: sort voted first

Hi Dizzy,

I was able to get this to reproduce on one of our Mali chipsets, whereas the device I originally had was using the Adreno chipset. Looks to be an issue there really. I've submitted a ticket for this to be investigated and you can follow the status here: https://issues.unrealengine.com/issue/UE-38961

Thanks!

Tim

more ▼

answered Nov 22 '16 at 06:58 PM

avatar image

Tim Hobson ♦♦ STAFF
49k 886 99 875

avatar image dizzynoob Nov 23 '16 at 09:47 AM

Ah... It's the Mali chipsets problem, indeed i tried on Mali GPU instead of Adreno. Thanks.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question