x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Shader Complexity for instanced foliage

Hi, I'm using version 4.13.1  . The trees pictured here are the same model. The tree on the Left was placed with the instaced foliage tool. The tree on the right was just dragged into the scene. both have LOD's and are low poly.
Any idea of why this is happening? 
I'm working on a VR game and my instanced foliage is wrecking my frame rate.

thanks!

Product Version: Not Selected
Tags:
framerate.jpg (425.9 kB)
more ▼

asked Oct 15 '16 at 01:19 AM in Rendering

avatar image

ESIDESIGN
25 5 8 11

avatar image ESIDESIGN Oct 15 '16 at 02:19 AM

for some reason my question didn't post. trying again. Basically, the tree on the left and tree on the right are the same model. The tree on the right was just placed in the level and tree on the left was placed using instanced foliage tool. I was able to fix the material complexity issue by checking " use as occluded" in the instanced foliage details box but that is causing this weird black glitch to happen on the trees when they LOD. Does anyone know a way around this shader complexity issue? It is killing my framerate. shooting for 90 fps and getting drops to 45/60 when looking at the instanced foliage.

avatar image JohnADaniels Jan 16 '19 at 01:33 PM

I have the exact same question!! Did you ever get this figured out???

avatar image ESIDESIGN Oct 16 '16 at 09:17 PM

anyone????

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question