x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] Camera near clipping plane

Is it possible to change the value for near clipping plane on created cameras? I have huge troubles with camera clipping through geometry, especially when trying to set up a first person matinee with a gun and what-not.

Thanks!

Product Version: Not Selected
Tags:
more ▼

asked Mar 11 '14 at 02:58 AM in Using UE4

avatar image

ue4-archive ♦♦ STAFF
49.9k 3660 1983 9111

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 02:58 AM

Can somebody adress any performance or other issues we should be aware of when modifying the clipping plane?

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 02:58 AM +

The main problem you will see with pushing the near plane closer to zero is that you will lose a lot of depth precision which can lead to z-fighting.

avatar image Mowfax May 07 '14 at 10:52 AM

I would REALLY like to have a near clipping per Camera, too! Please consider making this setting available in the properties of the camera.

avatar image TJ V ♦♦ STAFF May 07 '14 at 01:12 PM

Hi Mowfax,

This is an archived post. If you are experiencing a similar issue please feel free to create a new question on AnswerHub or post on the forums.

Thank you, TJ

(comments are locked)
10|2000 characters needed characters left

The question has been closed May 07 '14 at 01:12 PM by TJ V for the following reason:

Archived Post


2 answers: sort voted first

Currently this is not possible. I went ahead and threw this into our database for consideration.

thanks!

more ▼

answered Mar 11 '14 at 02:58 AM

avatar image

ue4-archive ♦♦ STAFF
49.9k 3660 1983 9111

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 02:58 AM

Thanks a lot for your answer! :). Follow up question: How would one solve this issue for now then without this setting? How do other FPS-games in UE4 solve this? I noticed that the clipping issue disappears if I scale the arms and gun up a lot, is that the solution? Or is there a code-based better solution?

Thanks again!

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 02:58 AM

Hi Markus, in the engine INI:

 [Engine.Engine]
 NearClipPlane=20.0

^^ Set that config value to whatever you'd like the near clip plane to be.

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 02:58 AM

I'm bumping this because I'm trying to change this value and I don't see any change currently.

I have tried (inside the DefaultEngine.ini of my project) :

 [Engine.Engine]
 bSmoothFrameRate=true
 MinSmoothedFrameRate=22
 MaxSmoothedFrameRate=62
 NearClipPlane=0.1
 
 [UnrealEd.EditorEngine]
 bSmoothFrameRate=true
 MinSmoothedFrameRate=15
 MaxSmoothedFrameRate=62
 NearClipPlane=0.1

While the smooth framerate option works inside the editor, the NearClip option seems to not have any effect at all. I have tried very small and very big value but the clipping remain the same.

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 02:58 AM

I don't know myself. I've reassigned this thread to one of our awesome programmers who may be able to help you. :-)

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 02:58 AM

NearClipPlane was not a regular class property, so UnrealEd.EditorEngine did not inherit it, which is why your INI change had no effect. I have fixed this in CL# 1902831, and I have also exposed this setting in the Settings UI under Project Settings -> Engine -> General Settings -> Settings where it will remain until we refactor all Engine settings and find a better place for it.

The way it's set up right now (the value is being cached in a global variable), you won't be able yet to tweak this setting on the fly, but will have to restart the Editor for changes to take effect (or at least recreate the view ports).

These changes did not make it into the upcoming Beta 5, but they will be available in Beta 6. In the meantime stick with the Engine.Engine INI setting as suggested above. Thanks!

(comments are locked)
10|2000 characters needed characters left

this worked for me:

 MyProjectFolder/Config/DefaultEngine.ini
 [Engine.Engine]
 NearClipPlane=2.0
more ▼

answered Mar 11 '14 at 02:58 AM

avatar image

ue4-archive ♦♦ STAFF
49.9k 3660 1983 9111

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 02:58 AM +

In the main viewport of the Editor I don't see any change, even if I change the BaseEngine.ini setting. :(

(comments are locked)
10|2000 characters needed characters left

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question