x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why does my floor not render on my phone?

I am running the game on an android phone (Samsung galaxy s5)... the walls are fine but the floor has the checkerboard texture and not the concrete texture that I have applied via the starter content material... I have got decals on top of my floor so is this causing the issue? Can you have decals on android?

Also it is exporting to my phone with the texture format ATC... my phone does support this however is it possible to change the texture format at all?

I can provide a screenshit is required.

Any help is much appreciated.

Thanks.

Product Version: UE 4.13
Tags:
more ▼

asked Oct 17 '16 at 04:21 PM in Packaging & Deployment

avatar image

Tommow
15 13 17 18

avatar image Matthew J Oct 17 '16 at 05:48 PM

Hello Tommow,

In a situation like this, it would be best to check the log file from the packaging process for any warnings that may of indicated an issue with this missing texture. You can find the log file in your project's directory under Saved/Logs. I would suggest doing a Find (ctrl+f) for the word "Warning" and seeing if you can find anything related to the texture possibly not being able to be loaded or anything of the sort.

If you have any questions about the log and/or can't find anything suspect, please post the log file here and I'll be happy to take a look.

avatar image Tommow Oct 17 '16 at 06:41 PM

I found one warning message...

[2016.10.17-00.22.46:129][ 0]LogUObjectGlobals:Warning: Failed to find object 'Class None.'

Any idea what this means?

avatar image Matthew J Oct 17 '16 at 06:55 PM

It would be best if you could supply the whole log if you have any questions. That particular error usually doesn't point to anything. I've seen it in many logs but it's never been the cause of any issues as far as I know.

avatar image Tommow Oct 17 '16 at 06:58 PM

Here is the log, Thanks again :)

link text

log.txt (39.9 kB)
avatar image Matthew J Oct 17 '16 at 07:08 PM

I'll need to ask about changing the texture format but, is it possible that this texture is larger than what the phone supports? Android in general is limited to 2048x2048. You can find more guidelines here: https://docs.unrealengine.com/latest/INT/Platforms/Mobile/Textures/

avatar image Tommow Oct 17 '16 at 07:15 PM

I am using the 'M_Concrete_Tiles' material which is in the Starter Content, I do not know what texture to look for as the material has a few different ones... its a complex material compared to what I make... do you think it could be the decals?

avatar image Matthew J Oct 18 '16 at 05:56 PM

It's likely the decal but, in general, decals can be used on Android. Could you take a screenshot of your decal's properties? Just to test that it wasn't the texture, I packaged with that same texture set to a few things and it showed up without a problem.

avatar image Tommow Oct 18 '16 at 07:03 PM

Here is the decal material that I have applied over my floor.alt text

decal material.png (424.5 kB)
avatar image Matthew J Oct 18 '16 at 07:29 PM

Is it possible that you're using baked lighting when on Android? If so, you may need to enable "DBuffer Decals" under Project Settings > Rendering. This is an experimental feature so it may cause some other issues but this will allow for the use of deferred decals with baked lighting.

avatar image Tommow Oct 18 '16 at 08:08 PM

My light is set to stationary, and lighting is built before packaging, I have ticked the box you said under the rendering tab and restarted the ue4 editior... uninstalled from phone, re-packed it and the floor still shows as checkerboard pattern... any further ideas? Could it be my texture format?

avatar image AndrewHurley Oct 18 '16 at 09:15 PM

Hey Tommow,

So I have a few suggestions that might resolve the issue. In the Project Settings > Rendering section try enabling the 'Movable in Early Z-pass' and enabling the 'Early-Z Pass' as well.

Also, remember that if you are using the default Translucent Decal Blend Mode, it will not render with baked lighting. So if you have built your lighting, that decal won't render as you expect.

Thanks,

Andrew Hurley

avatar image Tommow Oct 18 '16 at 10:19 PM

I have tried movable and changed that setting to enabled but still the same checkerboard pattern :(

avatar image Matthew J Oct 27 '16 at 04:03 PM

Hello Tommow, since we're having issues getting the same results as you with the same sort of code, would it be possible for you to send a small project that reproduces this issue so that I can see where the discrepancy is? You can either upload it here or send it to me directly via a download link in a private message on our forums.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

We haven't heard from you in a while, Tommow. Are you still experiencing this issue? If so, would it be possible for you to send me an example project so that I can reproduce this? In the meantime, I'll be marking this issue as resolved for tracking purposes.

more ▼

answered Nov 18 '16 at 07:44 PM

avatar image Tommow Nov 20 '16 at 07:55 PM

Hey, I have not been working on ue4 in a while due to my full time employment. The last time I was working on it I was getting the same issue... It seems to be the decals, they do not seem to render on mobile phones, not sure why.

avatar image Matthew J Dec 21 '16 at 05:07 PM

Hello Tommow,

I still haven't been able to reproduce this locally. As mentioned in my comment from Oct 27th, it would be useful if you could provide a project that you are able to reproduce this issue in, as it could be either code or asset related.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question