x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Error when Launching / Failed Packaging

I've searched high and low for a solution to my problem, but I'm stuck and need some help.

I have a project that uses a third party library plugin that I'm developing. Everything works fine when previewing in the editor, either just in the viewport or as a standalone or VR. However, all goes to hell when I try and use the Launch feature.

The following issues pop out in my log:

 LogInit:Display: Starting Game.LogLinker:Warning: Can't find file '/Script/U4DPlayer'

U4DPlayer is the name of my plugin, but I don't seem to have any scripts by that name. Is this somehow missing or important? Can this warning be ignored?

 LogProperty:Error: Struct type unknown for property 'StructProperty /Game/Blueprints/U4DDeveloperConsole.U4DDeveloperConsole_C:UpdateThreadsWidget.CallFunc_GetMetrixThreads_ReturnValue.CallFunc_GetMetrixThreads_ReturnValue'; perhaps the USTRUCT() was renamed or deleted?LogWindows:Warning: CreateProc failed (2)

This is being thrown by one of my blueprints. The struct in question is defined. I've tried replacing it, everything compiles fine. I also tried changing the LoadingPhase of the plugin to "PreDefault" which was suggested elsewhere with no improvement.

Any help is appreciated. Full log attached.link text

Product Version: UE 4.13
Tags:
fulllog.txt (26.1 kB)
more ▼

asked Oct 18 '16 at 07:26 PM in Packaging & Deployment

avatar image

StealthOne
11 2 5 7

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Ok, I think I have this sorted actually. The plugin type was "Developer". I've switched it to "Runtime" so it's actually available at runtime.

more ▼

answered Oct 18 '16 at 08:05 PM

avatar image

StealthOne
11 2 5 7

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question