x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why is my Cubemap getting resized when imported?

Hey,

I have a cubemap that I am using for a space sky sphere, I have created the cube map following the instructions set out in the docs, everything goes fine and the texture maps to the mesh correctly however, the texture is modified by the importer which changes the scaling which leads to a blurred texture I guess because the pixels are re sampled and stretched.

What should I be doing here to avoid the blurring? I've tried with textures of varying sizes so 512 x 512, 1024 x 1024 (6 images of each for each axis) but its always the same blurry image after importing as the image looks fine in Photoshop.

Would appreciate any suggestions,

Thanks.

Product Version: Not Selected
Tags:
more ▼

asked Jun 02 '14 at 10:27 AM in Rendering

avatar image

Maddius
146 14 20 24

avatar image Maddius Jun 02 '14 at 11:27 AM

It sounds like this passage from the docs is what is happening:

"The cubemap used for ambient lighting. The texture should be created by importing a .hdr image in the longitude/latitude sphere unwrapping format. The engine automatically precomputes blurry versions of the texture and stores the result in one cubemap texture. The lower resolution mips of the texture store the diffuse preconvolved version of the HDR environment."

https://docs.unrealengine.com/latest/INT/Engine/Content/Types/Textures/Cubemaps/UsingCubemaps/index.html

How do I avoid this?

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hi Maddius -

You will want to open the Texture in the Engine and change the Mip Gen Settings under Level of Detail. You can try a few but one of the Sharpen ones should fix up the blurry problem you are getting.

Thank You

Eric Ketchum

more ▼

answered Jun 02 '14 at 04:07 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 702 256 733

avatar image MadScorp Sep 01 '14 at 12:16 AM

You just can set Mip Gen Settings to NoMipmaps

avatar image hynzla Feb 13 '19 at 08:00 PM

Setting Mip Gen Settings to NoMipmaps doesn't work for me. My HDR is locked at 512x512x6 despite this setting change.

(comments are locked)
10|2000 characters needed characters left

Thanks for the reply however,

Looks like this (https://forums.unrealengine.com/showthread.php?2568-How-to-implement-a-standard-cubemapped-skybox) thread has the answer which is pretty much what I expected, all images are down sampled to 512 which causes the blur.

UE4 seems to be geared towards procedural skies.

Thanks

more ▼

answered Jun 02 '14 at 07:38 PM

avatar image

Maddius
146 14 20 24

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question