x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.13 VR Template Problem Teleporting

alt textHi there. I have a problem that is causing me to pull what is left of my hair out and I hope someone can help.

I have imported an architectural model from Revit via Max as an FBX file (about 8000 separate meshes) and having enclosed the whole building in a single navmesh am having problems getting the VR template teleportation system to work.

Its a multi-level building with some complex geometries. The navmesh generated is a little wierd, it has to be said: quite patchy and with navigable areas being generated "in mid air".

When I try to teleport the teleport arc appears as a blue ball in my "hand" and the target arrow appears directly below my hand position allowing me only to make little "steps" forward.

Does anyone have any idea what is going on here? I would appreciate being able to advance this project.

Cheers!

Product Version: UE 4.13
Tags:
screencap.jpg (162.8 kB)
more ▼

asked Oct 19 '16 at 03:28 PM in VR

avatar image

berkal929
1 1 2 2

avatar image MieszkoZ STAFF Oct 19 '16 at 07:34 PM

It sounds like you have a lot of invisible collision. Have you tried show collision? Navmesh generating in mid air suggests there's walkable (blocking) collision where you wouldn't expect it.

avatar image berkal929 Oct 20 '16 at 02:50 PM

OK thanks for the reply. I looked at player collision and changed most of the asset default collision settings to complex which seems to have cured my initial problem of not being able to teleport. It seems that the default complex and simple setting created blocking volumes that were too coarse and encompassed large spaces meaning that my pawn was trying to teleport inside of a blocking volume I guess returning an invalid navmesh location in the BP.

I still have issues regarding the floating navmesh areas and navigating on stairs but I think it's just a matter of playing with the collision settings.

Cheers!

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question