x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

collision not working on newly imported models without autogenerate collision first.

collision not working on newly imported models without autogenerate collision first. Steps to reproduce. If you export from maya.. then import without any collision... then try to use complex collision... the collision doesnt work.

In contract if you import a model with auto generated collision, then proceed to delete collision , and finally use auto generate as collision... then it works... no idea why.. been experienceing this on like the last 50 models i imported.

This is also going to be a major time waster for me since most of my environment has been built, but half of it probably doesnt have collision working and i will have to test every single mesh individually... wether its doorarches... or walls... or peices of trash....

Product Version: UE 4.13
Tags:
more ▼

asked Oct 19 '16 at 06:30 PM in Bug Reports

avatar image

kurylo3d
464 46 82 108

avatar image kurylo3d Oct 19 '16 at 06:40 PM

To add to this a way to make complex collision work is to quickly add a box collision and then delete it and hit save... the complex collision seems to work after that, but i dont want to have to go through potentially hundreds of models to do this for all of them since i know many of these will have problems.

And another thing... which is unrelated... some models materials come with enable collison checked to off by default... this is not my issue with most of my models, but its just another problem.

To make matters worse.. there is a specific order u have to do thigns to fix it... First u have to enable the materials collision, then add a box simplifixed collision, then delete collision... and save.. then it works.. If you try to do it in any other order it does not fix the collision for complex collision.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Sounds like auto-generate is generating simple and complex collision as it is meant to do. When you have it off then no collision is generated; simple or complex. So it makes sense that if you have no collision then collision detection will not work. When you delete collision I imagine that you're only deleting the simple collision and not complex. Either way this seems to be working as intended and if you're only using complex collision then you should probably just have auto-generate on.

more ▼

answered Oct 19 '16 at 06:37 PM

avatar image

QSBen
413 16 15 31

avatar image kurylo3d Oct 19 '16 at 06:38 PM

wrong... if i create a box collision... then quickly delete it... then complex collision seems to work... Complex collision is supposed to just go off teh regular model.

That is the only answer to this problem that i will have to recheck every mesh and do that to every problem mesh which is messed up since this never used to be the case... right now by default its not recognizing use complex as collision until i add a box collision then quickly delete the box collision.

avatar image QSBen Oct 19 '16 at 07:44 PM

That may be the case but regardless, adding collision causes it to work so my question is: is there a real reason why you want auto-generate collision off?

avatar image kurylo3d Oct 19 '16 at 07:48 PM

Because autogenerate collision on makes it box collision. I want the mesh to be my collision. Autogenerate forces me to go in and delete it first.

avatar image QSBen Oct 19 '16 at 08:18 PM

you can force it to use complex (per poly) collision instead of simple collision by going into your static mesh settings and changing your collision complexity to 'Use Complex Collision as Simple'. That way it will use your complex collision even if you have simple colliison.

avatar image kurylo3d Oct 20 '16 at 12:49 PM

Your not getting it.. That doesnt work. Thats the bug. Switching to use complex collision as simple... should just work. But instead if i import with no autogenerate collision it does not work.. the option is broken unless u do things in a very precise order....

avatar image QSBen Oct 20 '16 at 04:20 PM

I am getting it. I am telling you to use autogenerate, the simple collision that is generated should not matter if you use 'Use Complex Collision as Simple'. I don't understand why you are so insistent on not using auto-generate collision.

avatar image kurylo3d Oct 20 '16 at 06:08 PM

because it adds an extra step and i never had to do that. I dont want to have to delete the autogenerated collision every time i import. This is a recent engine version problem.. I beleive it started with 4.12 It is also very confusing... took me hours to figure out why.. im sure other people will have the same issue.. an option should just work.. u shouldnt have to create collision geometry that u dont want then delete it.. it makes no sense.

Do you not agree that the option use complex as collision... should actually use the complex geometry as the collision? I mean right now it doesnt unless u create some random collision object and delete it first...

avatar image Tim Hobson ♦♦ STAFF Oct 26 '16 at 09:20 PM

Hey Kurylo3D,

There was a deliberate change when the new mesh LOD system was introduced allowing you to use a selected LOD as your collision mesh. This required a change in how the option for "Enable Collison" was handled under the material elements as well because in order for the selected LOD to have collision work the specific LOD's material had to have "Enable Collision" checked.

If you're not using any lower LODs for your collision mesh and are just using the base mesh, I could see where the problem could be. I can enter a feature request to consider any mesh that is using only a single LOD that needs complex collision to keep that enabled by default and only disable it if there is more than one LOD.

As QSBen mentioned, though, everything is working as intended.

-Tim

avatar image kurylo3d Nov 04 '16 at 05:51 PM

Understood. Thanks for the response!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question