x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why AActor or AVolume classes from my plugin doesn't visible in editor class viewer?

I just made test plugin which is based on BlankPlugin, UObjectPlugin, CableComponent samples and it's looks like successfully loaded in plugin manager, but I can't find any classes from plugin in ClassBrowser or on ModesTab.

Declaration of my classes:

 #pragma once
 #include "BlankPlugin2Object.generated.h"
 
 
 /**
  * Example UStruct declared in a plugin module
  */
 USTRUCT()
 struct FBlankPlugin2Struct
 {
   GENERATED_USTRUCT_BODY()
  
   UPROPERTY()
   FString TestString;
 };
  
 
 /**
  * Example of declaring a UObject in a plugin module
  */
 UCLASS()
 class ABlankPlugin2Object : public AActor
 {
   GENERATED_UCLASS_BODY()
 
 public:
 
 private:
 
   UPROPERTY()
   FBlankPlugin2Struct MyStruct;
 
 };



 #pragma once
 #include "PlanetoidNavMeshVolume.generated.h"
 
 UCLASS()
 class APlanetoidNavMeshVolume : public AVolume
 {
   GENERATED_UCLASS_BODY()
   
   // Begin AActor Interface
   virtual void PostInitializeComponents() OVERRIDE;
 #if WITH_EDITOR
   virtual void ReregisterAllComponents() OVERRIDE;
   // End AActor Interface
   // Begin UObject Interface
   virtual void PostEditChangeProperty( struct FPropertyChangedEvent& PropertyChangedEvent) OVERRIDE;
   // End UObject Interface
   
 #endif // WITH_EDITOR
 };

It's looks like I forgot to register my classes somewhere or something like that, but I have no idea where.

Also here is My Plugin Full Source Code

Product Version: Not Selected
Tags:
blankplugin2.zip (29.5 kB)
more ▼

asked Jun 02 '14 at 03:35 PM in C++ Programming

avatar image

strobe
1 5 10 13

avatar image BiggestSmile Jun 03 '14 at 06:37 PM

I experience some weird problem with AVolume derived classes inside plugin as well.. Exactly whenever i enable plugin that has AVolume based class it crashes engine during loading then..

Checked if it's exactly AVolume - it is. Replaced with ABrush - it worked, but crashed later, when i tried to place the box. Tried APhysicsVolume - same as AVolume, as it's AVolume derived class itself.

avatar image strobe Jun 04 '14 at 08:39 AM

ok, if AVolume and ABrush is buggy - that about AActor? - in my case ABlankPlugin2Object also doesn't available in editor classes view

avatar image BiggestSmile Jun 04 '14 at 08:44 AM

Check my answer below, you don't have constructor code for your class, so there's no actor available in the editor.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Regarding your situation, you initialize ANavMeshBoundsVolume inside PlanetoidNavMeshVolume.cpp

more ▼

answered Jun 03 '14 at 06:42 PM

avatar image

BiggestSmile
1.6k 54 38 105

avatar image strobe Jun 04 '14 at 08:47 AM

what I have to add to current PlanetoidNavMeshVolume.cpp implementation (from blankplugin2.zip)?

avatar image strobe Jun 04 '14 at 08:49 AM

CableComponent has AActor class which I able to see in editor class viewer, why in my case AActor (ABlankPlugin2Object) didn't available in editor?

avatar image BiggestSmile Jun 04 '14 at 08:58 AM

You should change ANavMeshBoundsVolume to APlanetoidNavMeshVolume inside PlanetoidNavMeshVolume.cpp

To place these actors you most likely have to open "Class view" window and search for these actors.

avatar image strobe Jun 04 '14 at 09:01 AM

oh, thank - I guess I little tired, that doesn't not notice about it

avatar image strobe Jun 04 '14 at 09:15 AM

I had fix this (attachment archive updated also), but anyway I can't see those classes in class view

avatar image BiggestSmile Jun 04 '14 at 09:24 AM

Well, no idea then.. Are you sure you enabled this plugin in plugin manager?

avatar image strobe Jun 04 '14 at 09:47 AM

yep, here is a Screenshot Screenshot

avatar image BiggestSmile Jun 04 '14 at 11:30 AM

Can't check sorry.. Your plugin crashes engine as well.. Using main branch as for 05.15.14 IIRC..

Try disabling filters in class view, see if it helps.

avatar image strobe Jun 04 '14 at 11:52 AM

thanks, filters disabled already.

I use 4.1.1

avatar image strobe Jun 06 '14 at 05:27 PM

I just retested this on 4.2 and situation still same

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question