x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

auto convex collision doesnt do anything.

I click auto convex collision on my mesh settings.... and it does nothing. Takes a split second and no outcome.. just does nothing. Box simplified works... remove collision works.. all that works... but auto convex does nothing at all..

I imported the model regularly with autogenerate collision set on. I remove collision then try to do auto convex and theres just nothing there.... Any ideas?

Product Version: UE 4.13
Tags:
more ▼

asked Oct 21 '16 at 06:39 PM in Bug Reports

avatar image

kurylo3d
464 46 82 108

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

5 answers: sort voted first

Make sure that you have "Enable Collision" Checked for all materials that you want contributing to the collision calculation of Auto Convex Collision. alt text

That setting is checked, by default. I was scared though, and turned it off, because in collision preview mode all materials turned on will display a blue wireframe around the static mesh. alt text ^Technically, this above image has no collision, as collision meshes have either a green or purple wireframe color. I assumed that setting was to use per-vertex collision, but instead it is just to display which meshes will be considered when collision is generated. If "Enable Collision" is off for all materials, the Auto Convex Collision's "apply" button does nothing.

more ▼

answered Jan 01 '18 at 08:15 PM

avatar image

JonathanArmstrong
57 6 9

avatar image VictorBurgos Feb 16 '18 at 12:56 AM

Aye confirmed. Just ran into this issue. Have to make sure LOD has "Enable Collision" toggled on. Next to "Cast Shadow"

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi kurlyo3d,

The Auto Convex Collision in the Collision dropdown only opens the Convex Decomposition window (bottom-right by default). You then have to adjust those setting and hit apply.

alt text

alt text

If I misunderstood what you are see, please let me know.

Cheers,

TJ

autoconvex01.png (185.4 kB)
autoconvex02.png (74.0 kB)
more ▼

answered Oct 25 '16 at 08:22 PM

avatar image

TJ V ♦♦ STAFF
41k 1009 183 494

avatar image kurylo3d Oct 26 '16 at 02:28 PM

Yes you misunderstood. I mean after i hit the apply button nothing happens. Instantaneous non reaction. Collision visibility is on... it just doesnt even bother to calculate since its instant.. i even try accuracy to full and max hul lverts 32... still instant with no output.

avatar image TJ V ♦♦ STAFF Oct 26 '16 at 08:32 PM

Okay, after some further testing I think see what the issue is. In the Details panel > StaticMeshSettings > CollisionComplexity > do you have 'UseComplexCollisionAsSimple' enabled?

If so, change that back to ProjectDefault to see the collision being created. I'm going to investigate further but I will likely enter a bug report for the collision not being displayed when 'UseComplexCollisionAsSimple' is enabled. However, the sphere, capsule, and box are all displayed. So it's possible that the bug might be the opposite, that no collision is expected be displayed when it is enabled.

I'll post back here with the JIRA report number once it's entered.

avatar image kurylo3d Oct 26 '16 at 09:01 PM

That could be the problem, though im still trying to figure out which mesh i used during that moment i noticed it wasnt working. Only reason i need to figure that out is because it didnt even bother calculating... where as right now it calculates on another mesh but isnt visible as u said until usecomplexcollisionassimple is disabled.

Or maybe im remembering it wrong, but in either case as of right now its working when i disable use complex as collision. Thank you!

avatar image Tim Hobson ♦♦ STAFF Oct 26 '16 at 10:01 PM

Auto Convex Collision generation requires that "Enable Collison" be checked under the LOD material element. I've responded similarly on your other post that covers this as well here: https://answers.unrealengine.com/questions/510084/collision-not-working-on-newly-imported-models-wit.html

This was a deliberate change in 4.12 when Selective LODs for Collision Mesh were introduced.

avatar image kurylo3d Jan 18 '17 at 01:40 PM

im now using 4.14.3 and its broken again. Collision is active in the lod... collision complexity is on project default.... ive tried every setting in that drop down.. The auto generate collision simply is not working at all. Any ideas?

Any freshley imported model simply cant use auto generate collision. Very frustrating.

Update**

I have created a new bug report here since the problem now goes way beyond not being able to auto generated convex collision... its developed into a crashable bug with repeatable steps.. every time..

https://answers.unrealengine.com/questions/550716/collision-generation-options-do-nothing-and-someti.html

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I was having some issues with no collision happening after converting a group of actors to a new static mesh.

Specifically, I was trying to use Auto Convex Collision and nothing was happening. I saw collision primitives on the mesh but no option to remove them, too. This was even after creating simple box collision primitives and selecting Remove Collision; the new box primitives would disappear but the primitives that existed on the new static mesh after conversion remained.

The solution for me was to do what TJ said: Details > StaticMeshSettings > CollisionComplexity, set to Project Default. Auto Convex Collision worked after that.

more ▼

answered Dec 29 '16 at 05:56 PM

avatar image

Lawsonry
31 1 2 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I was having this problem too, but this solution didn't work for me. However, there's another UE4 answerhub question that fixed my problem, here:

             https://answers.unrealengine.com/questions/496360/did-something-change-with-convex-collision-generat.html
more ▼

answered Aug 16 '17 at 02:30 PM

avatar image

xaot88
31 9 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I've tried about every suggestion that I can and I still get nothing but a progress bar that seems to be hung up. Missing something?

Thank you!

Mac 10.13.6 UE 4.19.2

alt text

more ▼

answered Oct 16 '18 at 04:39 PM

avatar image

braveFactor
1 1

avatar image JonathanArmstrong Oct 19 '18 at 04:35 PM

What are your default settings for the hull calculation? Maybe yours is set too high? It definitely increases the calculation time if the hull precision in increased. This is the standard:

alt text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question