x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Source Code Build Fail - MSB3073

Hello all, While trying to build the source code version of UE4 (The Microsoft ATG Version, which according to Engine\Source\Runtime\Launch\Resources\Version.h is 4.13.1)

i get a build error (see log attached) link text

Things i have tried

Re-unzipping Re-download of zip Reclone Via GITHUB Tried on two different Hardrives VS2015 Is being run in admin mode

i shall try the pure version of UE4, And update the post

EDIT: Pure UE4 Also failed, Log bellow. also instaler version of UE4 Works fine pure error

Product Version: Not Selected
Tags:
log1.txt (13.1 kB)
pure error.txt (2.7 kB)
more ▼

asked Oct 21 '16 at 06:12 PM in Installation & Setup

avatar image

MACH2Simulations
198 9 12 19

avatar image Tim C ♦♦ STAFF Oct 25 '16 at 02:47 PM

Hi Mulldoon,

From the log you provided for the ATG version of UE4, it looks like the Windows 8.1 SDK is missing a file (nldef.h). Could you try reinstalling the 8.1 SDK to see if that helps?

The log for the UE4 source code build that you provided does not indicate what the actual problem is (The MSB3073 error message just indicates that something failed, but does not specify what failed). I was not able to reproduce any build failures in the release branch. What branch or tag did you download from our repo?

Tim

avatar image MACH2Simulations Oct 28 '16 at 09:50 AM

just an update, visual studio broke so im having to reinstall that, but luckily that includes the necessary SDKS will update once finished

and it was the release branch at the time of writing the post,

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hello, for the pure version of UE4 Updating/Reinstalling Visual studio worked

due to the ATG Version seeming to be needing the Win10 SDK i have had to use a W10 virtual machine and installing everything to that and that has seemed to work

more ▼

answered Oct 29 '16 at 04:59 PM

avatar image

MACH2Simulations
198 9 12 19

avatar image Tim C ♦♦ STAFF Nov 01 '16 at 04:03 PM

Hi Mulldoon,

I am glad to hear that it appears to be working for you now. Just to make sure that you are aware, it should be possible to install the Windows 10 SDK on other versions of Windows. I have the Windows 10 kit installed and I am using Windows 7.

Tim

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question