x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] Shadows calculated for shadow-disabled lights

I've been having the (already reported, yet disappointingly not-fixed) issue of shadows being calculated for lights of radius 0, resulting in a huge ShadowDepths render time - however, in trying to find ways to provide a temporary fix whilst testing the performance of the game, I have created a simple blueprint that goes through all the pointlights every couple of hundred milliseconds and disables those beyond a certain distance.

Whilst this works in disabling the shadows being rendered in the viewport, the ShadowDepths remains huge even when I set the custom shadow-disabler distance to 0m

Product Version: UE 4.14 Preview
Tags:
more ▼

asked Oct 23 '16 at 08:31 AM in Bug Reports

avatar image

Oscar Cooke-Abbott
542 54 59 73

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Nov 02 '16 at 03:47 AM by Oscar Cooke-Abbott for the following reason:

Was caused by own-error


1 answer: sort voted first

Good day,

That is a known issue.

A workaround would be to use Set Cast Shadows on Light Component. Hope that resolves your problem.

more ▼

answered Oct 24 '16 at 01:02 AM

avatar image

Deathrey
7.9k 130 31 293

avatar image Oscar Cooke-Abbott Oct 24 '16 at 01:34 AM

That's what I'm doing though. As I said in the question, I'm setting them to not cast shadows, yet shadows are still being calculated.

avatar image Oscar Cooke-Abbott Oct 24 '16 at 06:54 AM

I don't know why you marked this as an answer Tim, because as I said - the problem is that 'Set Cast Shadows: false' does not stop the shadows from being computed.

avatar image Deathrey Oct 24 '16 at 07:36 AM

I've actually re-checked that before answering, Oscar.

Setting influence radius or intensity to zero results in shadows still being calculated. However as for setting Cast Shadows variable, I have correct, expected and measurable ShadowDepth render time reduction when doing so. I've tested it on directional,point and spot lights, both dynamic and stationary. 4.13.1 version.

Perhaps You could provide in-depth info about the scene in question to get more specific assistance. Also, for your information, You can remove that answered status on the question yourself.

avatar image Oscar Cooke-Abbott Oct 24 '16 at 07:42 AM

The blueprint itself is fairly complex as it is a random generation system - however the light component system is simple: It creates a bunch of point lights, then at runtime it disables them all on begin Play. The shadows disappear, although the shadow calculation still appears and consumes alot of frame time in the GPU Profiler.

avatar image Deathrey Oct 24 '16 at 11:56 AM

Both Set Visibility and Set Cast Shadows results in expected shadow time rendering reduction for me.

avatar image Tim Hobson ♦♦ STAFF Oct 31 '16 at 07:24 PM

Just to chime in here. The ticket above is referencing the issue you've described. This is something we'll look at resolving for 4.15 and is some fallout from refactoring the rendering code previously.

If you suspect this to be a separate issue that doesn't is just disabling shadows and having them calculated can you please list detailed steps to reproduce the issue or a simple project that can reproduce the issue. From what I've seen shadows are currently only being calculated if the intensity has been set to 0, but not when shadow casting has been turned off.

avatar image Oscar Cooke-Abbott Nov 02 '16 at 03:44 AM

Sorry, I solved the issue separately - though it was unrelated to the other rendering bug of which you are speaking

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question