x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Curves in Cascade using Emitter Time do not read past 1.0 Seconds

This is a bug that's been reported a few times here, and has been plaguing Cascade for years - any curve that uses the emitter time (instead of particle lifetime) as the X axis doesn't read values after X=1 second. So as a user, I have no ability to animate things like initial velocity/size/color/alpha, emission rate, location offset, etc past one second.

https://answers.unrealengine.com/questions/331165/particle-initial-velocity-curve-only-animates-to-1.html https://answers.unrealengine.com/questions/284998/emitter-duration-not-being-respected.html

I've recently had an engineer look into this, and he was able to correct it quickly, so I'm hoping we can pass this fix back up to epic.

Product Version: UE 4.10
Tags:
more ▼

asked Oct 23 '16 at 01:13 AM in Using UE4

avatar image

keith.guerrette
99 5 11 24

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Yes, it should, but it doesn't... which is the entire reason for this post...

I was a little dumb founded that you aren't seeing this issue, and I couldn't tell if it's because you weren't bothering to check, or because it's since been fixed. I grabbed an install of 4.13.1 and tested it there again - it is working correctly in 4.13.1, but not earlier versions (4.10.4).

So great - problem solved!

more ▼

answered Nov 08 '16 at 05:18 PM

avatar image

keith.guerrette
99 5 11 24

avatar image Luos Nov 08 '16 at 05:44 PM

that is really odd, as I was dumb founded you did have that issue hehe :)

TBH never bothered to check the situation in 4.10, and been using 4.12 since its release. (4.13 has some other bugs with cascade)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

In that case, make sure emitter duration (in required module) is identical (or longer) than the length of those curves.

that should solve it.

more ▼

answered Oct 24 '16 at 07:30 AM

avatar image

Luos
9.3k 286 64 330

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I think you are just not understanding how curves work. 0 = begin of particle. 1 = end of particle.

problem solved.

that said, it would be nice to have an option to switch between "0-1 space" and "over time". As a vfx artist, I never ever had issues with it, not even the ones mentioned in the two links you provided.

more ▼

answered Oct 23 '16 at 10:05 AM

avatar image

Luos
9.3k 286 64 330

avatar image keith.guerrette Oct 23 '16 at 11:04 PM

I suspect you're not understanding the difference between emitter time and particle lifetime. What you described is particle age normalized (aka lifetime). However, the modules I described actually use emitter time (i.e. time since the emitter turned on), so you can do things such as change the spawn rate over the duration of the effect (obviously you don't want to control the rate of particles spawned over the age of one particle?), or even the animation of the initial location of the effect. These types of controls are crucial to making an interesting effect and as a fellow VFX artist, they're badly missed ;)

I run into this every semester when teaching my students, and have to explain that this is a silly lingering issue in Unreal. So no, definitely not problem solved.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question