x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

TickComponent is not executed in ue 4.13

Hello guys,

I was using TickComponent in ue 4.10 an it worked. I upgraded at 4.13 and now TickComponent is no more executed. This is the method:

 void UEditingComponent::TickComponent(float DeltaTime, enum ELevelTick TickType, FActorComponentTickFunction *ThisTickFunction)
 {
     Super::TickComponent(DeltaTime, TickType, ThisTickFunction);
     GEngine->AddOnScreenDebugMessage(-1, 5.f, FColor::Yellow, TEXT("this text is never printed"));
 }

This is where i create the component:

 UpEditLunghezza = NewObject<UEditingCone>(this);
     if (UpEditLunghezza)
     {
         UpEditLunghezza->RegisterComponent();
         UpEditLunghezza->AttachToComponent(RootComponent, FAttachmentTransformRules::KeepRelativeTransform);
         UpEditLunghezza->Constructor(1, Raggio * 2.3f, ConeMesh, EditableNormalMaterial, EditableSelectedMaterial, GrowCurve, this);
 }

Constructor in a method where I inizialize the component, inside this method I tried everything to tick the component:

     PrimaryComponentTick.bCanEverTick = true;
     PrimaryComponentTick.bStartWithTickEnabled = true;
     RegisterAllComponentTickFunctions(true);
     bTickInEditor = true;
     bAutoActivate = true;
     bAutoRegister = true;
     SetComponentTickEnabled(true);
     PrimaryComponentTick.TickGroup = TG_PrePhysics; 


in the 4.10 version with only bCanEverTick and bStartWithTickEnabled it worked. The actor tick work properly.

Any ideas?

Product Version: UE 4.13
Tags:
more ▼

asked Oct 23 '16 at 04:31 PM in C++ Programming

avatar image

Opocio
11 2 3 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I just moved "PrimaryComponentTick.bCanEverTick = true" from the constructor to beginplay and now it works

more ▼

answered Jan 10 '17 at 10:02 PM

avatar image

Opocio
11 2 3 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I've noticed in 4.14.2 if I add TickComponent to a c++ component while that component was already part of a blueprint, I need to delete it from the blueprint then compile/save and re add it or it will never tick.

more ▼

answered Jan 10 '17 at 07:03 AM

avatar image

HyperToxic
26 1 4 7

avatar image Opocio Jan 10 '17 at 10:01 PM

thanks for the answer but I have already figured out the problem some times ago, now I mark solved

avatar image UE4Course Jun 04 '17 at 02:51 PM

Thanks! Works for me (UE 4.16)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question