x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnimNotify calling both run and walk at same time?

alt text

So I was really happy about getting AnimNotify to work on creating a walking sound in UE4 on the default skeleton/mesh/animation/graph .. however, when attempted to add a new set of notifies for the running animation, the walking animation is happening at the same time causing doubled-up sounds.

To validate this, I added Print Strings to my notifies, one for each foot, and each animation. While the character is in it's "walk" animation, I was getting a print for run and walk at the same time, but when I started running, only the print for the run notifies was happening.

So basically, it looks like while the character is only using the walk animation sequence, it's blending in a "slow" version of run as well.

Product Version: Not Selected
Tags:
animnotifybug.jpg (97.6 kB)
more ▼

asked Jun 03 '14 at 01:10 AM in Using UE4

avatar image

Mixitman
6 3 6 6

avatar image Wes Bunn ♦♦ STAFF Jun 04 '14 at 03:10 PM

Hello,

Would you be able to post some images of your setup so that I may try to reproduce this?

Thanks,

-W

avatar image Rehven Oct 01 '14 at 05:28 PM

I'm getting the same kind of issue too.

Notifies in the animations: alt text alt text

Made a sound cue and duplicated it to a different name, to see if that was the issue. It wasn't.

And here's a video of the problem: http://youtu.be/8ouv2sS7Vvw

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey MixitMan and Rehven,

I believe what you are seeing/hearing is a blending of the notifies on both the Walk and the Run Animation Sequences. If you're using a Blend Space to combine the two, by default it will attempt play all notifies for all AnimSequences being run in the Blend Space.

You can change this to only play notifies for the highest weighted animation. In your Blend Space asset, open the Anim Asset Details panel. Under Animation Notifies, switch the Notify Trigger Mode from All Animations to Highest Weighted Animation. Now, only the notifies of the animation with the heighest weight (viewable in the Blend Space graph) will fire.

Hope that helps!

more ▼

answered Oct 02 '14 at 05:59 PM

avatar image Rehven Oct 02 '14 at 07:41 PM

That fixed it for me, thank you Ben.

avatar image G2Gmusic Sep 09 '16 at 02:57 AM

Hi, I have the same problem and although changing to Highest Weight mode fixed it, there is no sound between idle and walk when Idle is highest but there is still steps happening that would need sound. Is there a way to work around and exclude Idle state or something?

avatar image Matt.Williams Sep 16 '16 at 04:09 PM

Hi G2Gmusic,

This is a very old post and a lot of functionality here may have changed. Also this user no longer exists. Please post a new thread in the Using UE4 section or on the forums.

-Matt W.

avatar image Pharmadude Oct 08 '18 at 06:32 PM

That fixed it for me, too. Thanks a lot :D

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question