x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Media Source File Importe Problem

Hello, when I import a video (for a video texture)(I have tried with wmv, mp4, mov, avi, file), I have this:

alt text alt text

I can't use it for a video texture.

Product Version: UE 4.13
Tags:
videotext1png.png (72.6 kB)
videotext2.png (71.1 kB)
more ▼

asked Oct 24 '16 at 10:43 PM in Using UE4

avatar image

CarlMckayre
33 10 12 11

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

I have the same problem before and I solved with this: https://docs.unrealengine.com/latest/INT/Engine/MediaFramework/HowTo/FileMediaSource/index.html

Guess 4.13 has changed the whole workflow of media texture,but i don't like this way at all,it takes much more steps.

more ▼

answered Nov 11 '16 at 07:16 AM

avatar image

zeelem
26 2 2

(comments are locked)
10|2000 characters needed characters left

If you want to package the video with your game, it must be located inside your project's /Content/Movies directory

more ▼

answered Oct 24 '16 at 11:13 PM

avatar image CarlMckayre Oct 25 '16 at 11:04 AM

It doesn't work, i have the same issue.

avatar image CarlMckayre Oct 25 '16 at 11:47 AM

I've tried to create a media player and a media texture (based on the media player). I can launch the video through the media player and the video texture work but when i close the media player, the video is no longer assigned to the media player and video texture.

avatar image gmpreussner STAFF Oct 25 '16 at 03:16 PM

Try to manually assign the video texture to the MediaPlayer and save the player asset. There is currently a bug where the MediaPlayer asset is not being marked as dirty if you create a media texture or media sound wave via the context menu in the Content Browser, so the Editor won't tell you that you need to save the MediaPlayer, and you'll lose the binding of the media texture when closing the Editor.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question