x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

PC to iMac - Remote Build Fails : Failed to run init commands on 192.168.0.6. Output = Permission denied (publickey,password,keyboard-interactive).

Hi,

I have been trying to remote build from my PC to my iMac for a couple of weeks now, but have hit a brick wall.

I have followed the guides on answer hub and various posts, and seem to have things configured to the book. I have the certificate and mobile provisions setup correctly and working, rsync is setup, so is Deltacopy, unreal remote build settings and ssh key seems to be working ok, I have setup unreal on the mac and pc from source and have double checked permissions etc... Both the PC and Mac can see each other on the network.

However when I try and package my project for ios, it goes the best part of the way through things successfully until it gets to this part in the log when it complains about permissions. I don't know what is happening here, and would really appreciate some help in getting to the bottom of this, so if anyone has come across this error before then please put me out of my misery :-) :

UnrealBuildTool: Failed to run init commands on 192.168.0.6. Output = Permission denied (publickey,password,keyboard-interactive). UATHelper: Packaging (iOS): UnrealBuildTool: Failed to initialize a connection to the Remote Server 192.168.0.6 UATHelper: Packaging (iOS): UnrealBuildTool: Doing xcode-select --print-path UATHelper: Packaging (iOS): UnrealBuildTool: Execute took 00:00:01.5801991 UATHelper: Packaging (iOS): UnrealBuildTool: Compiling with non-standard Xcode (xcode-select): Permission denied (publickey,password,keyboard-interactive)./ UATHelper: Packaging (iOS): UnrealBuildTool: Doing ls Permission denied (publickey,password,keyboard-interactive)./Platforms/iPhoneOS.platform/Developer/SDKs.......................

Product Version: UE 4.13
Tags:
more ▼

asked Oct 24 '16 at 11:22 PM in Packaging & Deployment

avatar image

i-design
41 2 3 4

(comments are locked)
10|2000 characters needed characters left

4 answers: sort voted first

I managed to resolve this issue.

What I needed to do was navigate to the RemoteToolChainPrivate.key file in windows explorer > right click > properties> security (tab) > edit (button) > Add the 'Users' group and assign 'Full Control'.

IMPORTANT - Remove all other users and groups assigned to this file, leaving only the 'Users' group with full control.

more ▼

answered Oct 29 '16 at 03:54 PM

avatar image

i-design
41 2 3 4

avatar image invisiblebattles Sep 11 '17 at 02:59 AM

What type of users? Just the administrators? What did you define for object names?

avatar image patrick58d Oct 31 '17 at 03:27 PM

Thanks so much for this tip. This did the trick for me, I was stuck for a bit, but once I removed all other groups except "Users" it worked like a charm.

avatar image Michela Nov 01 '17 at 11:44 PM

alt text No luck for me on Win10. I removed inheritance so all groups removed bar Users but still getting same error as per screenshot

screenshot-4.png (21.1 kB)
avatar image Michela Nov 02 '17 at 12:06 AM

Ah success! An additional step was required. After changing properties as above, the Project Settings | Found Existing SSH permissions file went blank

(previously autofound key in UnrealBuildTool\SSHKeys\)

Assigned (same) key in the Override existing SSH Permissions file field below and voila, connection made.

(comments are locked)
10|2000 characters needed characters left

what windows you try this? i'm trying on windows 10 but no luck...

more ▼

answered Sep 18 '17 at 10:51 AM

avatar image

GizmoMKD
6 3 7

(comments are locked)
10|2000 characters needed characters left

To reiterate, you need to open the file's security tab, and delete ALL the users/names/admins listed there. Then Manually add the user group by clicking Advanced->Add->Select a Principle and manually type in 'USERS' here: alt text

capture.jpg (82.8 kB)
more ▼

answered Mar 10 '18 at 03:17 AM

avatar image

Trandana
47 4 4 9

(comments are locked)
10|2000 characters needed characters left

Tried setting permissions as suggested and still got the same error.

What eventually worked for me was moving the RemoteToolChainPrivate.key file to a different directory, and then manually choosing it under "Override existing SSH permissions file" in the Project Settings.

In my case I just copied it to the DeltaCopy dir.

more ▼

answered May 20 '18 at 06:36 PM

avatar image

kreshnov
21 1 2

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question