x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Connecting multiple clients on a Dedicated Server

Hi everyone!

I'm currently working on a Game that needs to be builded for a Multiplayer use.

I've followed this tutorial to setup and build correctly a Dedicated Server:

https://wiki.unrealengine.com/Standalone_Dedicated_Server

So right now I've a Packed Client and Dedicated Server that works very fine in lan and even over ip.

The problem is that I can't connect more than one Client in my server. What happen is this:

The first Client Connects without any problem:

alt text

The second one fails: alt text

Please help me to understand what's the problem and how to fix it :)

Product Version: Not Selected
Tags:
client1.jpg (259.5 kB)
client2.jpg (452.1 kB)
more ▼

asked Jun 03 '14 at 11:12 AM in Packaging & Deployment

avatar image

Maximvm
44 5 6 14

avatar image Maximvm Jun 03 '14 at 11:15 AM

I do not know why but my question was pulled 5 times, and I don't see any tool to delete the other questions,

Please refer this as the main post.

I'm sorry if I did something wrong

avatar image [Epic] John Pollard STAFF Jun 05 '14 at 11:00 PM

What appears to be happening looking at the logs, is the server received an unexpected packet while the second client was logging in. Are you doing anything out of the ordinary or using stock code here?

avatar image Maximvm Jun 05 '14 at 11:30 PM

I absolutely didn't anything out of the ordinary since I don't even know where to look to manage the login access and communication data between a Server and Client. As I wrote before I just followed that tutorial to build with visual studio a dedicated server .exe and put in the packaged development game.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hello,

Thank you for your report. We were not able to investigate this on the engine version you reported, but there have been many version changes to UE4 since this question was first posted. With a new version of the Engine comes new fixes and it is possible that this issue has changed or may no longer occur. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes. If you are still experiencing the issue you reported in the current engine version, then please respond to this message with additional information and we will investigate as soon as possible. If you are experiencing a similar error, that is not 100% related, could you please submit a new report for it.

Thanks!

more ▼

answered Apr 03 '15 at 06:27 PM

avatar image

[Epic] Gribbs ♦♦ STAFF
11.8k 292 14 77

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey Guys.

I'm getting the exact same error. I'm trying to move my pawn on the client and synchronizing all the clients & server but making use of a (NetMulticast) function. However the client doesn't load and I'm using a Listen Server.

 UFUNCTION(NetMulticast, Reliable)
         void MoveForward(float Value);
 
 void ABasePlayerClass::MoveForward_Implementation(float Value)
 {
     if (Controller && Value != 0.0f)
     {
         AddMovementInput(FRotationMatrix(Controller->GetControlRotation()).GetScaledAxis(EAxis::X), Value);
     }
 }

Having a look at your code, I see you are also using a Multicast function, maybe there something wrong there ?

more ▼

answered Jun 16 '14 at 04:26 PM

avatar image

Ad3ViLl
96 12 21 20

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

We had this exact same problem, and like the other answer here the cause was a NetMulticast RPC getting spammed by the server to a client while it was connecting. Changing the RPC to a replicated variable instead fixed the issue entirely (in our case there was no real reason for it to be an RPC anyway).

I guess that technically this is a bug in UE4, but it's not impossible to work around it. That is, unless sending any NetMulticast RPC while a client is connecting causes the problem (rather than just spamming one), in which case it could cause some nasty seemingly random connection failures.

more ▼

answered Jul 07 '14 at 04:48 PM

avatar image

Stanith
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question