x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

customized Pak File Contains EditorOnly Data

Hi~all.Here is the thing.

I packaged some uasset into a .pak file and then try to load it during runtime.

When I am in the editor mode,everything work fine.I can mount the pak file and load the resources inside it.

However,When I package project using Win64.I can mount the pak file but cannot load the resources inside it...

What surprise me most is that if I run the code in the Class Constructer,I can load the resources in pak file.But if

I run the code in BeginPlay() or other function,it doesn't work..It's really werid...

I had checked the log file. It said that the pak file contains editor only data.I have cooked the uasset before i

packaged it into the pak file...

I'll be glad to hear any response...

Log: [2016.10.29-03.50.21:915][ 0]LogClass: Mount Success

[2016.10.29-03.50.21:915][ 0]LogLinker:Warning: Unable to load package (../../../Engine/Content/M_AssetPlatform.uasset). Package contains EditorOnly data which is not supported by the current build.

[2016.10.29-03.50.21:915][ 0]LogLinker:Warning: Unable to load package (../../../Engine/Content/M_AssetPlatform.uasset). Package contains EditorOnly data which is not supported by the current build.

[2016.10.29-03.50.21:915][ 0]LogUObjectGlobals:Warning: Failed to find object 'Object /Engine/M_AssetPlatform.M_AssetPlatform'

[2016.10.29-03.50.21:915][ 0]LogStreamableManager: Failed attempt to load /Engine/M_AssetPlatform.M_AssetPlatform

[Here is the Code][1]

Thanks [1]: /storage/temp/112911-code.txt

Product Version: UE 4.12
Tags:
code.txt (2.1 kB)
more ▼

asked Oct 29 '16 at 06:04 AM in Using UE4

avatar image

DennisDing
65 4 9 11

avatar image SimplestWay Jul 11 '19 at 09:06 AM

Hi, have you soved your problem? I met the exactly problem like yours. After several hours of searching in google, nothing founded except your question, please help me if you can, thank you so much!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question