x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Problem with planar reflections with more than 1 actor in the scene.

I have 1 planar actor and it works perfectly. When I add a 2nd one, the 1st one gets very very blurry. Sometimes it will even lose all his reflective proprieties.

Is there something I'm doing wrong?

If I hide the 2nd actor, the 1st become clear again... Can we not have more than 1 planar actor? It used to work before iirc.

I made a video to show the problem in the editor, but it's the same thing when I launch the game. Here it is : link text

Product Version: UE 4.13
Tags:
more ▼

asked Oct 29 '16 at 08:30 AM in Rendering

avatar image

heartlessphil
6 1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

The single mesh makes it clear what this is. Transparency only supports applying the closest planar reflection (determined per-object) much like only the closest reflection capture is applied.

more ▼

answered Nov 03 '16 at 04:30 PM

avatar image

DanielW STAFF
1.9k 31 11 72

avatar image heartlessphil Nov 04 '16 at 04:14 AM

So is it just a limitation and working as intended or it could be fixed to work with a big single mesh. The sole reason why this scene was imported as a single mesh it's because it's on the heavy side and slow (4000+ objects from 3ds max)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey Phil,

I'm attaching a project here that I did as a test.

link text

There are two maps here.

  • PlanarTest: Similar to your setup with multiple tiers and translucent material. This has a total of 3 planar reflection actors scaled to fit the windows.

  • PlanarTest2: This is a room with 5 planar reflection actors for each wall and a single dynamic object rotating in the center. For me, all of these work and have been scaled to the reflective surface.

If this is working for you and you see all the planar reflections, I would suggest going into your project and deleting the Intermediate and Config folders. This should reset your project settings. You will have to re-enable any settings you had in the Project Settings like "Support Global Clip Planes" for Planar Reflections, but this could possibly show if something were corrupted.

You didn't mention in the original post, but did you try any other projects or a new blank project to see if it was only affecting this particular project?

Let me know!

Tim

more ▼

answered Oct 31 '16 at 04:07 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 888 103 878

avatar image heartlessphil Nov 01 '16 at 04:16 AM

Hey Tim!

Ok, I tested on a brand new default 1st person template, I can get more than 1 planar actor working perfectly. The scene you sent me also works fine.

Then I tried to delete the 2 folders you suggested, reopened my project, reactivated global clip plane, restarted. The problem is still there. Weird.

Maybe I can give you more infos about my scene. The whole building is 1 big mesh. I'm only using a movable sun and movable skylight.

avatar image Tim Hobson ♦♦ STAFF Nov 02 '16 at 07:12 PM

That nailed it! Having the mesh as a single asset made it very reproducible.

I found a couple of issues when trying this. Using a similar setup to your scene with three levels would cause only a single reflection plane to work at a time. However, using a box inset and having reflective faces inside would do something similar if I had a reflection plane for all interior faces. They would work in Editor but in PIE or using Game View (hotkey G) would only use 2 of them out of the 4 I placed. Certainly something worth investigating and thanks for your report!

I've submitted a ticket for this that you can track here: https://issues.unrealengine.com/issue/UE-38140

Thanks!

avatar image heartlessphil Nov 03 '16 at 05:05 AM

Good work! Thanks for the help.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question