x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] How to - FULLSCREEN - packaged build ?

Dear community, I must be overlooking something simple here.

I would like to be able to run packaged projects in full screen - the way the editor viewport would when f11 is pressed for "Immersive Mode"

What I seem to be getting is the windowed mode on launch and after pressing alt+enter - the build indeed does switch fullscreen but is still letterboxed (black borders on all sides)

I have played around with the 'New Window Size' values in Editor Preferences > Play > Play in New Window but that doesn't seem to change anything...

Would greatly appreciate any tips! Thank you, kindly.

Product Version: Not Selected
Tags:
more ▼

asked Jun 03 '14 at 07:44 PM in Packaging & Deployment

avatar image

EMERALD
21 1 2 5

avatar image BPANDREW Aug 10 '14 at 02:12 PM

this problably isnt the best way but i couldnt get that ini to not get blanked out even if i did it when my editor was closed. if i continue down this path I will create a save game object with all of these settings and have it react based on that on load

alt text

untitled.png (66.2 kB)
avatar image Shadowriver Aug 10 '14 at 02:17 PM

What INIs did you edited and where? for me this blanking is something that should not happen, you should be able to freely edit those default INIs

avatar image BPANDREW Aug 10 '14 at 02:19 PM

projectname\Saved\Config\CleanSourceConfigs\GameUserSettings.ini

probably the wrong one - i didnt try the ini route for too long - i dont mind doing it in blueprint/ui/savegames

avatar image Shadowriver Aug 10 '14 at 03:14 PM

As i said you need to keep in defults, inside defults, in Config/ directory and you create DefaultGameUserSettings.ini and place stuff there

avatar image BPANDREW Aug 10 '14 at 03:50 PM

cool thanks, just posting an alternative solution

avatar image knightshz Apr 05 '15 at 03:28 AM

Hi I am very new to this and interested in learning to create something possibly. I tried running the game and i got a horrible resolution im using a GTX970 nvidia so I know its not the card. Anyways you said put the "create an ini "? into a defaults directory, but that doesnt exist in the build I downloaded. So do i goto my directory which is Libaries\Documents\saved is the only place i see a folder called config is this where i create a folder called defaults and make an ini in notepad with the name you provided and then paste the info from your post??

avatar image Stormrage256 Apr 22 '15 at 03:48 PM

Hi does anyone know why Version=5 is added?

avatar image Slayemin Jan 13 '16 at 02:03 AM

Yes. If you look in "GameUserSettings.cpp", there is an enum which contains the current version number for these settings:

enum EGameUserSettingsVersion

{

 /** Version for user game settings. All settings will be wiped if the serialized version differs. */

 UE_GAMEUSERSETTINGS_VERSION = 5


};

As it suggests, the settings will only be active if the version number between the settings file and the engine match.

avatar image Savitus May 03 '15 at 02:43 PM

It would be great to have the default resolution settings for the packaged game available in the Project settings in the editor.

I was surprised that the Editor settings for "Play in Standalone Game" didn't carry over to the packaged game.

Even the "play in stand alone game" section doesn't have a fullscreen option. I had to add "-fullscreen" in Additional launch parameters to get the game to be fullscreen there.

avatar image srmojuze Jul 31 '15 at 05:35 PM

Hi, for Mac once the standalone binary starts a user can press Alt-Enter to go into fullscreen. Of course, automatically starting in fullscreen would be nice as per instructions above, etc.

avatar image JOhnRose81 Jan 29 '16 at 04:49 PM

Here's what I did: Open Level Blueprint Right Click and Type/Select "EVENT BEGIN PLAY" Right Click and Type/Select "Execute Console Command" In the Text Space Next to Command, Type "FULLSCREEN" Connect the Event Begin Play and the Execute Console Command Boxes (Connecting the two white triangle boxes)

avatar image Juxols Apr 12 '16 at 02:24 PM

SOLVED! Add the command "-fullscreen" to "additional Launch Parameters"!!!alt text

capture.png (59.2 kB)
avatar image Garf Snacks Apr 27 '16 at 05:27 PM

Unfortunately this doesn't work for packaged games, only in editor standalone

(comments are locked)
10|2000 characters needed characters left

The question has been closed Aug 17 '16 at 07:37 PM by Steve Hardister for the following reason:

Problem is not reproducible or outdated


0 answers: sort voted first

You need to set fullscreen in config files (if Project Settings does no have UI for it). In Config directory in your project directory you got your default config files, where in "Saved/Config" you got you current config files that editor uses. Configs with "Editor" and "Game" are compatible to eachother, but one is run for editor one is run on game. There should be GameUserSettings.ini with this:

 [/Script/Engine.GameUserSettings]
 bUseVSync=False
 ResolutionSizeX=1280
 ResolutionSizeY=1024
 LastUserConfirmedResolutionSizeX=1280
 LastUserConfirmedResolutionSizeY=1024
 WindowPosX=-1
 WindowPosY=-1
 bUseDesktopResolutionForFullscreen=False
 FullscreenMode=2
 LastConfirmedFullscreenMode=2
 Version=5

As you can see you got screen settings here :) set as you like and copy this file as DefaultGameUserSettings.ini in to Config directory and now this config gonna be used as game default config and when player will first run the game this config gonna be copied to Saved/Config as everything else in Config.

Update: People seems to not understand, so i say it again, you need to paste that in defaults in Config directory, not Saved/Config, you use Saved/Config just as example how to set up defults in Config directory. So you place code above inside DefaultGameUserSettings.ini and place it in Config directory (NOT in Saved/Config)

more ▼

answered Jun 03 '14 at 08:22 PM

avatar image

Shadowriver
33.9k 916 164 1093

avatar image EMERALD Jun 03 '14 at 09:29 PM

Understood!

avatar image Caiuse Jun 18 '14 at 03:32 PM

I can't get this to work, It keeps overriding the settings back to the original. Any advice?

avatar image Shadowriver Aug 01 '14 at 01:15 AM

The default setting getting overwrited?

avatar image oculushut Aug 01 '14 at 01:03 AM

Perhaps you need to edit it whilst the game is off? I seem to remember that in UDK the software would overwrite config files when you shutdown....

avatar image TimGS Aug 10 '14 at 03:43 PM

If you don't want to use ini you can also hardcode it in your GameMode class, just override BeginPlay() and implement it like that:

 void AMyGameMode::BeginPlay()
 {
     // ... your code ...
     
     if(GEngine)
     {
         UGameUserSettings* MyGameSettings = GEngine->GetGameUserSettings();
         MyGameSettings->SetScreenResolution(FIntPoint(1024,768));
         MyGameSettings->SetFullscreenMode(EWindowMode::Fullscreen);
         MyGameSettings->SetVSyncEnabled(true);
         MyGameSettings->ApplySettings();
     }
     
     // ... your code ...
 }
avatar image dbrizov Jan 04 '15 at 12:06 PM

Actually, for fullscreen, the FullscreenMode has to be 0, not 2. Also, If you don't want to use fixed resolution bUseDesktopResolutionForFullscreen should equal True

avatar image Shadowriver Jan 05 '15 at 02:54 PM

I just copy pasted my current setting as example, i assumed he will figure how to set up things

avatar image Kurt Dekker Jan 22 '15 at 12:15 AM

Depending on your browser, if you Select/Copy the config file lines posted by Shadowriver above, you may encounter blank spaces at the beginning of each line. When you paste those into your text editor, you may not realize that your lines all start with a space. YOU MUST REMOVE LEADING SPACES!

The .ini file parser used in Unreal is apparently either intolerant or pedantic of leading space characters on the left (key) side of .ini file lines, so this will cause your .ini file entries to have no effect.

Note to Unreal's forum moderators: could you perhaps implement a little "Copy to Clipboard" button that appears above and below any blocks of code posted on the Unreal forums? It would alleviate the above problem. :)

avatar image Bariton Jan 25 '15 at 03:29 PM

After building packages, there is no "saved" folder. But after playing game once, there is $EXPORT_FOLDER%\WindowsNoEditor\$GAME_NAME$\Saved\Config\WindowsNoEditor folder. Content of this GameUserSettings.ini file in this folder is normally empty.

Paste these all settings on that empty GameUserSettings.ini file (without line number). Then save it.

  1. [/Script/Engine.GameUserSettings]

  2. bUseVSync=False

  3. ResolutionSizeX=1600

  4. ResolutionSizeY=900

  5. LastUserConfirmedResolutionSizeX=1600

  6. LastUserConfirmedResolutionSizeY=900

  7. WindowPosX=-1

  8. WindowPosY=-1

  9. bUseDesktopResolutionForFullscreen=False

  10. FullscreenMode=0

  11. LastConfirmedFullscreenMode=0

  12. Version=5

Don't forget it, FullscreenMode=0. The trial game would be run in fullscreen mode.

Note: These settings could be also automatically generated while using blueprint/code to manipulate fullscreen mode in runtime by pressing a custom key made by user.

avatar image mpxc Jul 25 '15 at 12:05 PM

UE4.8:

Confirmed that adding a DefaultGameUserSettings.ini file to the Config folder (ala Shadowriver's response) will allow you to start deployed exes in fullscreen.

I used the following (make sure there are no whitespaces at the beginning of each line if copying):

 [/Script/Engine.GameUserSettings]
 bUseVSync=True
 WindowPosX=-1
 WindowPosY=-1
 bUseDesktopResolutionForFullscreen=True
 FullscreenMode=0
 LastConfirmedFullscreenMode=0
 Version=5

I removed the ResolutionSize and LastUserConfirmedResolutionSize lines because they were causing a default resolution different from my monitor, stretching the image. Also, FullscreenMode needs to be 0.

DefaultGameUserSettings.ini is copied automatically when deploying, so fullscreen works correctly by default when running the executable that is generated in Saved\StagedBuilds

avatar image cce Aug 01 '15 at 01:06 AM

I don't get it. My deployed application has no Saved/Config folder at all. This is very hard to follow.

avatar image mpxc Aug 02 '15 at 02:25 PM

Let me try to explain.

Before you deploy, in your project directory, there should be folders Build, Config, Content, Intermediate, Saved, etc.

In the Config folder there are files like DefaultEditor.ini, DefaultEngine.ini, etc. Note that there isn't a DefaultGameUserSettings.ini file by default. You can make it yourself and fill in the contents as I posted above. An ini file is just a text file so if you create a text file and save it as DefaultGameUserSettings.ini there will be no problem.

When deploying, the contents of this Config folder are copied over to project\Saved\Config\Windows. This is the folder that is referred to for config files when executing the exe file generated from deployment (the exe is in project\Saved\StagedBuilds\WindowsNoEditor). As a side-note, deployment is different from packaging, in which case everything appears to be getting packed into a .pak file. The contents of the config file appear to be getting built into the pak file so there's no problem.

avatar image Kensei Apr 30 '16 at 09:32 PM

You'd think such a thing wouldn't be so cryptic...I feel like Link lol :D

avatar image Steve Hardister ♦♦ STAFF Aug 17 '16 at 07:34 PM

Because various answers in this thread will work, I am closing this post because, as Kensei has pointed out, it is becoming rather cryptic and confusing to follow.

If you are still experiencing a problem having your packaged project start in full screen on it's intended device after UE 4.12.5, please create a new post for an up to date and more concise answer. -Thanks!

(comments are locked)
10|2000 characters needed characters left

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question