x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to brighten up normal maps/shadows ONLY?

Hi! I have stumbled upon two issues in connection to the brightness of shadows/normals in my level:

1) I would like to only brighten up the shadows in the level a bit, without making the rest of the level/lighting brighter.

2) I have a normal map, with increased insensitivity (by multiplying it with a V3) in order to achieve the desired level of roughness on rocks. However, that also results in some really dark spots, see image. Is there any way to brighten up the normal shadow color?

The scene has a directional light, skylight (cast shadows off), lightmass volume and all the standard stuff. Searching around the web, the most common answers are "add a skylight" or to increase environment color/insensitivity. Both option result in not only shadows being brighter, but also the whole level as you can see on the pic, which is undesirable. Neither seems to help addressing the dark spots on the normal maps, see the image. Any ideas what I can do? maybe there's some material trick to the normal maps?

alt text

Product Version: UE 4.10
Tags:
more ▼

asked Oct 30 '16 at 07:09 PM in Using UE4

avatar image

Araklaj
50 5 10 15

avatar image DaveEvodant Nov 29 '16 at 07:54 PM

I have the same question: All the shadows cast by geometry in my scene are grey, but the shadows from the normal map on the materials are black. The highlights, by contrast, are what I expect to see: light hitting the material adds a little highlight. But anywhere where there's shadows goes straight to black, creating a lot of weird contrast.

The material in this pic is in direct light: See how the highlights at the top of the bricks is nice and subtle, while the shadows at the bottom are black? How do I adjust that?

alt text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I think the two of you might actually be having different problems.

Araklaj, have you tried turning off ambient occlusion? It can be a post process effect and/or baked into the static lighting. See if that helps.

DaveEvodant, try placing a skylight in your scene, if you haven't already. If you have already done that, try increasing its intensity.

more ▼

answered Dec 07 '16 at 07:57 PM

avatar image

Wilkes
96 7 9 15

avatar image Fisher007 Mar 22 '17 at 11:21 PM

I always get this result, even with skylight. The actual mesh shadows are lit properly by it, but the normal maps cause some pitch black parts spots.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question