x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.13.2 rsync error

Hey there,

I am working on a windows 10 machine and I am remote building on a mac. A few days ago I updated the engine to 4.13.2 and I now cannot remote build anymore.

I get the following errors: UATHelper: Packaging (iOS): UnrealBuildTool: dup() in/out/err failed UATHelper: Packaging (iOS): UnrealBuildTool: rsync: read error: Connection reset by peer (104) UATHelper: Packaging (iOS): UnrealBuildTool: rsync error: error in rsync protocol data stream (code 12) at /home/lapo/packaging/rsync-3.0.4-1/src/rsync-3.0.4/io.c(791) [sender=3.0.4]

It worked fine back on 4.13.1 and I don't know how to fix this. I have already checked if the ssh connections has an issue but the error happens after the connection is established.

Is this a known issue or is this just on my end? What can I do to fix this?

-Joey

Product Version: UE 4.13
Tags:
more ▼

asked Oct 30 '16 at 09:47 PM in Bug Reports

avatar image

byteparrot
56 7 12 13

avatar image Samantha Sutton ♦♦ STAFF Oct 31 '16 at 06:35 PM

DJ_Joey,

Please upload your full error output logs.

Thanks!

avatar image byteparrot Nov 01 '16 at 04:36 PM

Hi, this is the output log of the editor: (error happens on line 34) https://www.dropbox.com/s/63f0w57ogtebcdo/errorlog.txt?dl=0

If I try to generate a new ssh key for the remote connection it also fails with the same error when trying to copy the key from the mac to my pc via rsync.

-Joey

avatar image Sean L ♦♦ STAFF Nov 02 '16 at 03:11 PM

Hey DJ_Joey,

Could you send me a screenshot of your Platforms-iOS screen in your project settings? Everything except for the icons would be great.

Also, have a look at this thread to double check that you've set everything up correctly: https://forums.unrealengine.com/showthread.php?78804-Windows-gt-iOS-Rsync-Remote-Build-Guide-(4-8)

Thanks

avatar image byteparrot Nov 03 '16 at 11:46 AM

Hi,

Here are the screenshots: alt text alt text

I will look through the thread as soon as I have time and then I will post here again, but as I said, the whole process worked before - so I really dont know why it doesn't anymore. Even the ssh connection works, only the rsync stuff doesnt work.

-Joey

avatar image Sean L ♦♦ STAFF Nov 07 '16 at 04:31 PM

Sorry for the delay. I'll actually need to take a look at your Bundle information, so if you don't want to share it publicly could you PM me the screenshots through the forums without those sections blocked out?

https://forums.unrealengine.com/member.php?160394-Sean-Flint

avatar image Sean L ♦♦ STAFF Nov 14 '16 at 03:39 PM

Thanks for the additional information.

Could you verify that Engine/Extras/ThirdPartyNotUE/DeltaCopy exists. DeltaCopy path exists and contains Binaries, Source, DeltaCopy.tps and DeltaCopy_License.txt?

Also is the project that you're working in a project that you've upgraded as well? If so, could you try a project that is newly created in 4.13.2 and not upgraded from a previous version?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello,

I am marking this topic as resolved for tracking purposes, as we have not heard from you in a few days. If this issue persists, feel free to respond to this thread. For any new issues, please create a new Answerhub topic.

Have a great day

more ▼

answered Nov 18 '16 at 04:36 PM

avatar image

Sean L ♦♦ STAFF
43.7k 485 152 440

avatar image byteparrot Dec 08 '16 at 07:51 PM

Hi Sean,

sorry that it took me so long to reply, it was very stressful the last few weeks. Good news is the problem looked like it solved itself by updating to 4.14

Thanks for the help. Best regards, Joey

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question