x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

d3dcompiler_47.dll is missing UE 4.13.2

Hello Guys! So a strange thing happened to me. UE4 seems to work but every time i start this pops up: program cant start because d3dcompiler_47.dll is missing. With 4.13.1 it worked just fine, 4.14.preview works just fine. When i updated to 4.13.2 this problem appeared. I am using windows 7 Best regards! Előd Somogyi

Product Version: UE 4.13
Tags:
more ▼

asked Nov 01 '16 at 02:55 PM in Bug Reports

avatar image

elodakielod
106 6 12 21

avatar image Sean L ♦♦ STAFF Nov 01 '16 at 03:19 PM

Hi elodakielod,

Have you tried reinstalling the engine version you're having the issue with? It's possible that the file became corrupted during the installation.

avatar image elodakielod Nov 02 '16 at 10:57 AM

Yes. I reinstalled it. But that did not solve the problem unfortunately.

avatar image Sean L ♦♦ STAFF Nov 02 '16 at 01:41 PM

Try one more thing for me:

  • Navigate to your AppData/Local/UnrealEngine folder and delete the 4.13 folder from that directory.

  • After doing this, attempt to reinstall one more time.

The reason I suggest deleting those files is that it will ensure that there is nothing remaining from the original installation, and is the only way to perform a completely clean reinstall.

avatar image elodakielod Nov 02 '16 at 03:09 PM

Unfortunately not even this fixed the issue.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Navigate to your Engine installation directory, and go to Engine/Binaries/ThirdParty/CEF3/Win64 and see if you have d3dcompiler_47.dll in that directory.

I'd also recommend making sure any antivirus software is allowing the program to run successfully, as it is possible that it could be interfering.

more ▼

answered Nov 04 '16 at 01:52 PM

avatar image

Sean L ♦♦ STAFF
43.5k 485 152 442

avatar image Laurent.Nvizzio Feb 02 '17 at 10:41 PM

Can we reopen this question? One of our users here has the exact same issue.

4.13, Windows7 -> UEditor displays the same error message. The DLL is present where you mentioned and its integrity cannot be questioned (it is used by all our users via source control).

I would surmise that there is something integral to Windows7 which causes this effect to trigger.

I tried all the aforementioned suggestions except reinstalling since we deploy our own built binaries via source control and only one of our users has this issue.

If any debugging/tracing is needed, I will gladly trace any code you want using the debugger to figure this out. At the moment, this makes it nearly impossible for this user to test his changes in game.

avatar image Sean L ♦♦ STAFF Feb 07 '17 at 06:31 PM

The only thing that I could think of would be that they need to install the Windows 8.1 SDK which contains this file. I've seen users have success with this regardless of whether they are running Windows 7 or Windows 8.

It's unusual that this would only occur on one system, but I'd recommend trying to have them install that SDK to see if that helps with the issue. I do not recommend downloading and replacing that .dll file individually, as it's meant to be shipped with an SDK.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question