x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

VR Preview Not Triggering OnlineSubsystem

So, not sure why I never noticed this, but while using the GameSparks plugin, occasionally I would not be able to get my leaderboards to work and then out of nowhere they would work. I tracked it down to Steam not being able to Authenticate. Long story short, VR Preview does not bring up the SteamOverlay so that means it's not also starting up the OnlineSubsystems.

To work around this, I can just do a "Standalone Game" and then OnlineSubsystems are opened up and Steam Authentication occurs. And when I go back to VR Preview, everything works.

Anyway, if there's some other way to force OnlineSubsystem(Steam) to open up during VR Preview, please let me know, thanks!

Product Version: UE 4.13
Tags:
more ▼

asked Nov 02 '16 at 01:12 AM in Bug Reports

avatar image

VictorBurgos
2.3k 59 26 108

avatar image Rudy Q ♦♦ STAFF Nov 02 '16 at 01:41 PM

Hello VictorBurgos,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. Does this issue still occur when GameSparks plugin is disabled?

  3. If the above are yes, could you provide a detailed list of steps to reproduce this issue on our end?

  4. Could you provide screen shots of any blueprints/settings that may be involved with this issue?

avatar image VictorBurgos Nov 02 '16 at 06:01 PM

Hey Rudy, so, this actually is occurring also on packaged projects. We've been testing it out. It may be something on GS' end with how they handle API keys when attached to games and when there are multiple projects (same game) with the same player utilizing the keys.

But, I still don't get why VR Preview does not open up the OnlineSubsystem(Steam) up on the first try (when using that to "open up the ports") ?

Our original thinking (during packaged) was that Windows Firewall just blocked it, but it would work later.

So that was wrong, but what about in Editor? What was causing this bug, why would it not refresh on the very first try, but then work and always work later.

Which led me to believe that VR Preview actually never opens up OnlineSubsystemSteam because the overlay never popped up. Which makes sense, but then it's like, okay, why does it work in VR Preview mode after we test the game out in Standalone Mode. Is there something in VR Preview preventing that initial connection? Only difference must be how OnlineSubsystem works or doesn't in VR Preview vs Standalone Game.

Then of course we have the "same" issue occurring in packaged game. The very first time, so could just be something on GS' end for packaging, but what about in the Editor?

So, my question is also, is VR Preview supposed to trigger OnlineSubsystemSteam or not?

avatar image GS_Liam Nov 02 '16 at 05:37 PM

Hi Victor,

I see you have opened a ticket with GameSparks also. We'll take a look at this from our end for you too.

Thanks, Liam

avatar image Rudy Q ♦♦ STAFF Nov 02 '16 at 06:43 PM

Hello VictorBurgos,

Thank you for the additional information, however I will need you to answer the questions from my original post in order for me to assist you further with this issue.

avatar image VictorBurgos Nov 03 '16 at 07:54 PM

This is looking more and more like an issue with the GameSparks servers/SDK and how they handle Authentication of new/old players than a UE4 issue.

But, an answer on why steam overlay doesn't happen on VR Preview would be nice.

avatar image Rudy Q ♦♦ STAFF Nov 04 '16 at 02:31 PM

The Steam VR overlay appears to be working in VR preview on our end. I was unable to reproduce that part of your issue. Does this issue appear in a clean project without the GameSparks Plugin enabled?

avatar image omakke Jan 08 '17 at 10:33 PM

I have same issue in 4.14.1

Steam Standalone works with Steam OnlineSubsystem, but the VR Preview does not trigger the overlay.

avatar image Rudy Q ♦♦ STAFF Jan 09 '17 at 01:54 PM

Hello omakke,

When you say that you are having the same issue, do you mean that you are using the GameSparks Plugin as well?

avatar image omakke Jan 10 '17 at 10:27 PM

No, I am not using GameSparks, sorry for the confusion. Here is what I found out as of version 4.14.1: In order to get OnlineSubsystem to trigger for Steam, you have to launch the game outside the editor. First it wasn't working from outside. After I packaged the game, it started working. I am thinking my Intermediate Folder or Saved was not updating properly.

avatar image project.gheist Jan 11 '17 at 09:25 AM

The engine currently does not support running the OnlineSubsystemSteam and other subsystems (I can confirm it is the same for the Oculus one as well) in editor preview mode (VR or otherwise). This is a limitation in the engine (most likely because of all the different ways you can run the game in editor eg. simulated, preview, ... and it is less error prone to not handle those cases). The only way to run subsystems successfully is in standalone mode or in a packaged build.

avatar image Rudy Q ♦♦ STAFF Jan 11 '17 at 07:26 PM

Hello omakke,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any blueprints/settings that may be involved with this issue?

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hello VictorBurgos,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

Thanks,

more ▼

answered Nov 08 '16 at 02:03 PM

avatar image

Rudy Q ♦♦ STAFF
47.9k 544 132 521

(comments are locked)
10|2000 characters needed characters left

This isn't a GameSparks issue. It's an Unreal one.

more ▼

answered Jan 11 '17 at 02:52 AM

avatar image

VictorBurgos
2.3k 59 26 108

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question