x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Windows and panels disappear. UE is driving me crazy

Okay, so here is what it looks like:

  • This issue is specific to one project Actually not. BP editor doesn't work in a blank new project;

  • Verifying Unreal Engine and plugins doesn't help;

  • If I enable GameAnalytics module from marketplace, blueprint editor won't work;

  • If I enable standard analytics and online subsystem plugins, then content browser won't work;

  • If I disable both GameAnalytics and standard analytic/online subsystem plugins, UE crashes at the project load (83%);

  • If I enable both GameAnalytics and standard ones, I will get content browser bug and/or blueprint editor bug;

  • deleting intermediate and saved folders solves either content browser bug or BP editor, but only one of them and till the next start.

The worst thing is that everything worked together for two days, and suddenly went mad.

I will try to determine which exact combination may cause the problem in blank project. It may also be somewhat connected with Steam Online Subsystem.

More info about specific bugs below ↓


Here is how BP editor looks for me:

alt text

As you can see, I have all the needed panels enabled:

alt text

Here is a non-working Content Browser:

alt text

Also, when the Content Browser is not working, I can't move freely in the level — the camera moves only back and forth: I can't look around, I can just zoom in-out and navigate with WASD. Also, the viewport refreshes only if I directly interact with it.

So now my project is frozen 'cause I just can't work in UE.

Product Version: UE 4.13
Tags:
more ▼

asked Nov 02 '16 at 09:53 AM in Bug Reports

avatar image

CosmoGorynych
44 1 5 9

avatar image Matthew J Nov 02 '16 at 02:56 PM

Hello CosmoGorynych,

I'm not having much luck reproducing this issue locally and will be looking into it further, but in the meantime, you may be able to fix this temporarily, although using the Analytics modules may cause this to occur again.

Navigate to your Appdata folder. This should be under your C:\Users\Username\ folder. It is a hidden folder so you'll need to enable being able to see hidden folders in the Control Panel > Folder Options > View if you haven't. Once you're in the folder, go into Local > Unreal Engine > Version number and delete all folders except for Content. This should reset these elements and make them visible again.

avatar image CosmoGorynych Nov 27 '16 at 08:27 PM

This doesn't help

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

We haven't heard from you in a while, CosmoGorynych. Are you still experiencing this issue? If so, have you tried what I mentioned in my previous comment? In the meantime, I'll be marking this issue as resolved for tracking purposes.

more ▼

answered Nov 10 '16 at 09:19 PM

avatar image CosmoGorynych Nov 27 '16 at 08:28 PM

Well, it returned again in 4.14.0

Possibly it reveals only after packaging a game (at least I did it 2 minutes ago and this popped out again).

avatar image CosmoGorynych Nov 27 '16 at 08:33 PM

Previously I switched to 4.14 preview 'cause I had no time for investigating this issue by myself. I know that this issue is extremely specific and hard to reproduce.

I feel the issue lies in GameAnalytics plugin. At least, it shows me lots of bugs while the packaging process. Looks like something is not documented about its setup.

I barely remember but suppose that previous bugs appeared at the time I tried making steam test builds with UE.

avatar image CosmoGorynych Nov 28 '16 at 12:10 PM

Something is really wrong. I uninstalled and reinstalled UE 4.14.0 and the issue popped out "out of the box", even though plugins were not installed.

avatar image CosmoGorynych Nov 30 '16 at 06:38 AM
avatar image Matthew J Nov 30 '16 at 04:59 PM

In 4.14, does this still happen with any project you create or is it only with your converted project? Could you provide log files from one of these sessions so I can see if there are any error/warning messages related to the blueprint editor?

avatar image CosmoGorynych Dec 02 '16 at 06:14 AM

Here are the logs: https://dl.dropboxusercontent.com/u/25234596/Logs.7z

The most important ones may be Bitmaster-backup-2016.11.28-08.08.08.log and Bitmaster-backup-2016.11.28-15.45.21.log

In 4.14, does this still happen with any project you create or is it only with your converted project?

It is still not limited to one project, even if I uninstall the plugin and only then create blank or open an existing project.

avatar image Matthew J Dec 02 '16 at 08:42 PM

It seems that there are also a lot of other 3rd party plugins that you're using that could be related to this. Can you try the following?

  1. Disable/remove all of your 3rd party plugins, anything that isn't enabled by default

  2. Delete the settings located in AppData again, under C:\Users\Username\AppData\Local\Unreal Engine\4.14

  3. Create a new project

After doing this, does the problem still persist? I'm trying to make sure that we're getting all of the third party content out of the way so that we know none of it is causing this. If the issue doesn't occur after that, we know that it is related to at least one of the plugins.

It seems like it's settings related due to messages like this as well:

 LogSlate:Warning: Tried to set viewport height size to -30765.  Clamping size to max allowed size of 16384 instead. 

Also, I never asked before since I didn't consider it to possibly be a hardware issue, but can you post your DxDiag information as well?

avatar image Matthew J Dec 22 '16 at 01:56 PM

We haven't heard from you in a while, Cosmo. Are you st ill experiencing this issue? Have you had a chance to try what I mentioned in my last comment? Also, can you check the answer by Ashh111 to see if that may help?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Any chance you are using the Russian characters in your UE/System/Middleware paths?

Seriously. :) There a chance this might be the issue.

more ▼

answered Dec 14 '16 at 07:17 PM

avatar image

Ashh111
1 2 6 8

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question