x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to fix object selection in a viewport? (mac)

The bug was inserted only in UE 4.13, before it was working good – so it's not only about the hardware.

It seems it's really depends on my graphic card (Intel Iris 6100), but in 4.12 it's working good – so, it's possible to fix.

If you need the same hardware build for tests – I can install a debugging version, provide logs or whatever needed… Or even can give you a remote access for debugging (teamviewer or anything else)!

Again, this bug was inserted only in 4.13, so it's definitely not about my hardware issue. Please do not "resolve" the bug without any solution – it should stay "Open" until fix.

The issue: I have did something with the viewport setup (I guess) and now when I'm selecting any actor (including a SkySphere – it's the most terrible) the actor becomes fully "outlined" in all projects – see the screenshot.

alt text

How can I disable such thing and make it by default only a "stroke" on selection? I've tried to reset to default setting – but it didn't helped. I've found that this "outline" could be turned off in Preferences -> Level Editor -> Viewports -> Use Selection Outline, but then the selected actor will not be highlighted at all... How to restore the default preferences?

[1]: https://answers.unrealengine.com/questions/517088/how-to-fix-object-selection-in-a-viewport.html

Product Version: UE 4.13
Tags:
more ▼

asked Nov 03 '16 at 05:26 AM in Bug Reports

avatar image

norlin
55 7 16 21

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi,

Just for future reference you don't have to make a new post to reopen an issue. When we say we are marking something as resolved it just means that the answer is accepted and you just have to comment on it to reopen the post.

As stated earlier, we don't have that particular GPU currently to test with (That led me to think that we didn't support the hardware you have but I was mistaken). I've talked to our QA department about this issue, and I apologize for the misunderstanding. For now I will have to enter a bug without reproducing it on my end.

You will find it here: https://issues.unrealengine.com/issue/UE-38212

All I can suggest at this point is changing your shader model to SM4 since this was the default in mac in 4.12 (see screenshot).

alt text

Other than that the developers will have to investigate this matter. Thank you for the Bug Post.

Ed

temp.jpg (54.9 kB)
more ▼

answered Nov 03 '16 at 05:29 PM

avatar image norlin Nov 03 '16 at 06:45 PM

Sorry for misundesrstanding and thanks for making the task.

BTW, changing the shader model didn't helped as well :( will wait for the fix...

avatar image BMC95 Mar 20 '17 at 05:53 AM

I'm getting this highlight issue with Intel Iris Pro 6200 also

avatar image Ed Burgess ♦♦ STAFF Mar 20 '17 at 03:56 PM

Cool, I updated the ticket with the new info. thanks for the update!

avatar image Pak0St Jun 27 '17 at 10:49 AM

On my Macbook Pro 13 Retina Early 2015 with Iris 6100 and UE 4.15.3, the highlight issue is there with Shader Model 4.

Interestingly enough, using the Default High-End Mobile Preview fixes the issue for me (bumping the ProcessorCountMultiplier is a must or you will wait forever for compilation to finish on this hardware).

Not bad, especially if targeting mobile devices to begin with.

avatar image Anry Narleyn Dec 01 '17 at 12:24 PM

Had same issue on same rig, confirm it being fixed switching to Default High-End Mobile Preview. Thank you for workaround.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question