x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Different graph during/completed task at Swarm Agent

On the first image there is a swarm agent on OCULO-PC and it's monitor during some task. OCULO-PC is not used, as SWARM1-PC is doing the task. Still, OCULO-PC's blue bar is moving forward. On the second screen there is a final OCULO-PC Agent after task is done. As you can see, the bar moved to the left indicating that no calculations were performed on OCULO-PC (and this one is correct).

Product Version: UE 4.13
Tags:
cpu not used1.jpg (60.7 kB)
cpu not used2.jpg (71.6 kB)
more ▼

asked Nov 04 '16 at 02:06 AM in Using UE4

avatar image

Wintch
1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Wintch,

From what you're showing here this is expected based on how Swarm distributes lighting builds depending on assignments.

https://forums.unrealengine.com/showthread.php?91714-Why-does-light-building-not-use-the-swarm-regardless-of-the-power-needed&p=423658&viewfull=1#post423658

If there are not enough tasks to assign out depending on the scene it may appear that one machine is not being used.

If you've got a substantially sized scene where a lot of tasks get distributed that would be a good indicator of what's going on. You can also look through the Swarm Agent log (set to Super Verbose in the settings for extra info too).

-Tim

more ▼

answered Nov 04 '16 at 05:07 PM

avatar image

Tim Hobson ♦♦ STAFF
49.6k 881 70 844

avatar image Wintch Nov 04 '16 at 05:20 PM

Thanks Tim, but my point is that the CPU on pc1 is not used, but the indicator is showing that both computers are. This is confusing as blue lines on pc1 should never move. Regards

avatar image Tim Hobson ♦♦ STAFF Nov 04 '16 at 05:28 PM

I believe that when the build is finished it should show this regardless. It's been a while since I've used linked system and I used them all without limiting either one.

You should be able to verify the build through the log for Swarm Agent.

avatar image Wintch Nov 04 '16 at 05:50 PM

AvoidLocalExecution is set to True on pc1, so no CPU is used on it. The problem are only moving bars that are giving you the sensation of the job being processed when it's not. After some slave finishes the work, the blue bars on pc1 disappears.

avatar image Wintch Nov 07 '16 at 05:02 AM

Checked that again. If i ignore blue bars, on preview second PC is not used. With production quality it is as i see 100% CPU load on both machines and total render time dropped. Still it is a bug as those blue moving bars at times are displaying incorrect status. Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question